Bug 1119803 - ECC supported curves list extension is missing in DTLS1 client hello
Summary: ECC supported curves list extension is missing in DTLS1 client hello
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: openssl
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Tomas Mraz
QA Contact: Hubert Kario
URL:
Whiteboard:
: 1153331 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-15 14:41 UTC by Tomas Mraz
Modified: 2015-03-05 11:03 UTC (History)
4 users (show)

Fixed In Version: openssl-1.0.1e-37.el7
Doc Type: Bug Fix
Doc Text:
The TLS extensions that were sent in the Datagram TLS (DTLS) ClientHello requests did previously not contain the list of the supported elliptic curves. As a consequence, the DTLS connections to servers using elliptic curves not supported by the OpenSSL client were aborted. With this update, the elliptic curve list extension is properly sent in the DTLS ClientHello requests, and DTLS connections are no longer aborted in the above circumstances.
Clone Of: 1119800
Environment:
Last Closed: 2015-03-05 11:03:44 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0478 normal SHIPPED_LIVE openssl bug fix and enhancement update 2015-03-05 15:44:08 UTC

Description Tomas Mraz 2014-07-15 14:41:55 UTC
ECC supported curves list extension is missing in DTLS1 client hello message. Because we do not support all of the ECC curves that are currently widely used this severally worsens the interoperability of DTLS1 protocol in our openssl package.

Upstream recently fixed this issue.

Comment 4 Tomas Mraz 2014-10-16 07:36:01 UTC
*** Bug 1153331 has been marked as a duplicate of this bug. ***

Comment 6 errata-xmlrpc 2015-03-05 11:03:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0478.html


Note You need to log in before you can comment on or make changes to this bug.