Bug 1119815 - bind needs network-online.target instead of network.target
Summary: bind needs network-online.target instead of network.target
Keywords:
Status: CLOSED DUPLICATE of bug 1117086
Alias: None
Product: Fedora
Classification: Fedora
Component: bind
Version: 20
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Tomáš Hozza 🤓
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: network-online.target
TreeView+ depends on / blocked
 
Reported: 2014-07-15 15:07 UTC by Corinna Vinschen
Modified: 2014-07-17 12:34 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-17 12:34:57 UTC


Attachments (Terms of Use)

Description Corinna Vinschen 2014-07-15 15:07:42 UTC
Description of problem: named starts before network initialization is complete

Version-Release number of selected component (if applicable): 
bind-9.9.4-12.P2.fc20.x86_64

How reproducible: Configure named to listen on explicit static interface address.

Steps to Reproduce:
1. reboot system

Actual results: named generates an error indicating its interface does not exist.

Expected results: named starts

Additional info: This is a generic problem with all services binding to explicit interface addresses and depending on network.target only.  network.target does not make sure that all statically configured interfaces are up.  Onle network-online.target does that.  Therefore the solution for all configurable services not supporting IP_FREEBIND is to change the dependency
from network.target to a depedency on network-online.target:

  Requires=network-online.target
  After=network-online.target

Other network services are affected as well so this bug  report is only one in a row.

Comment 1 Tomáš Hozza 🤓 2014-07-17 12:34:57 UTC

*** This bug has been marked as a duplicate of bug 1117086 ***


Note You need to log in before you can comment on or make changes to this bug.