Bug 1119822 - Add /etc/redhat-storage-release to sosreport collection
Summary: Add /etc/redhat-storage-release to sosreport collection
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sos
Version: 6.6
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: rc
: ---
Assignee: Shane Bradley
QA Contact: Miroslav Hradílek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-15 15:18 UTC by Wesley Duffee-Braun
Modified: 2015-07-22 06:32 UTC (History)
7 users (show)

Fixed In Version: sos-3.2-15.el6
Doc Type: Bug Fix
Doc Text:
No documentation needed.
Clone Of:
Environment:
Last Closed: 2015-07-22 06:32:50 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1323 normal SHIPPED_LIVE sos bug fix and enhancement update 2015-07-20 17:53:12 UTC

Description Wesley Duffee-Braun 2014-07-15 15:18:10 UTC
Description of problem:
When confirming the version of RHS installed, it is useful to examine the /etc/redhat-storage-release file, but this is not gathered by sosreport 

Version-Release number of selected component (if applicable):
sos-2.2-38

How reproducible:
Always

Steps to Reproduce:
1. Look for /etc/redhat-storage-release file in sosreport

Actual results:
Not found

Expected results:
File gathered by sos

Additional info:

Comment 2 Bryn M. Reeves 2014-07-15 17:41:42 UTC
It's a shame there's no os-release on RHEL6 variants; this would likely be a better source for this information.

I don't have any great in-principal objections to adding this (although it's one more straw..) but I'm curious what it buys us that's not available from e.g. installed-rpms or the gluster logs, config & tool output we collect?

Comment 3 Wesley Duffee-Braun 2014-07-15 17:51:05 UTC
Hi Bryn,

There are different ways to install gluster (or Red Hat Storage), and without doing a package-by-package comparison it can be difficult to discern the install method. Looking at the redhat-storage-release file helps show that the system was installed from an RHS iso/channel.

 - wesley

(In reply to Bryn M. Reeves from comment #2)
> It's a shame there's no os-release on RHEL6 variants; this would likely be a
> better source for this information.
> 
> I don't have any great in-principal objections to adding this (although it's
> one more straw..) but I'm curious what it buys us that's not available from
> e.g. installed-rpms or the gluster logs, config & tool output we collect?

Comment 4 Bryn M. Reeves 2014-07-16 09:54:16 UTC
OK thanks for the explanation. The main reason I ask is we're trying to record the reason for collecting new pieces of data in commits so that a few years down the line when we are reviewing what's collected we can understand the rationale behind each item and assess whether it's still relevant.

Comment 6 Bryn M. Reeves 2015-01-15 12:42:05 UTC
commit f382756db726af5f947805a0c10db9d69ddbc393
Author: Bryn M. Reeves <bmr@redhat.com>
Date:   Thu Jul 31 18:10:09 2014 +0100

    [gluster] add redhat-storage-release
    
    Fixes #329.
    
    Signed-off-by: Bryn M. Reeves <bmr@redhat.com>

https://github.com/sosreport/sos/issues/329

Comment 7 Bryn M. Reeves 2015-03-03 17:16:43 UTC
This is fixed as part of the rebase to 3.2.

Comment 10 errata-xmlrpc 2015-07-22 06:32:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1323.html


Note You need to log in before you can comment on or make changes to this bug.