Bug 1119850 - Rubygem-Staypuft: Nova-network HA deployment fails due to wrong glance parameters (pcmk_fs_device and pcmk_fs_dir ).
Summary: Rubygem-Staypuft: Nova-network HA deployment fails due to wrong glance parame...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rubygem-staypuft
Version: 5.0 (RHEL 6)
Hardware: x86_64
OS: Linux
high
urgent
Target Milestone: ga
: 5.0 (RHEL 7)
Assignee: Mike Burns
QA Contact: Leonid Natapov
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-15 16:17 UTC by Omri Hochman
Modified: 2014-09-08 05:44 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-04 18:35:50 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2014:1003 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Enhancement Advisory 2014-08-04 22:31:07 UTC

Description Omri Hochman 2014-07-15 16:17:42 UTC
Rubygem-Staypuft: Nova-network HA deployment fails due to wrong glance parameters (pcmk_fs_device and pcmk_fs_dir ).


Environmnet:
------------
ruby193-rubygem-staypuft-0.1.15-1.el6ost.noarch
rhel-osp-installer-0.1.0-2.el6ost.noarch
puppet-3.6.2-1.1.el6.noarch
puppet-server-3.6.2-1.1.el6.noarch
openstack-puppet-modules-2014.1-19.1.el6ost.noarch
foreman-1.6.0.21-1.el6sat.noarch
openstack-foreman-installer-2.0.14-1.el6ost.noarch


Steps:
------
(1) Install Staypuft from poodle  (2014-07-14.2)
(2) Attempt to run Nova-network HA deployment.

Results:
-------- 
Deployment stuck on 65% due to Glance issue. 


messages:
----------
Jul 15 01:53:35 525400702875 puppet-agent[3202]: (/Stage[main]/Quickstack::Pacemaker::Glance/Quickstack::Pacemaker::Resource::Service[openstack-glance-registry]/Pacemaker::Resource::Service[openstack-glance-registry]/Pacemaker::Resource::Systemd[openstack-glance-registry]/Pcmk_resource[openstack-glance-registry]/ensure) created
Jul 15 01:53:35 525400702875 Filesystem(fs-cinder)[23692]: ERROR: Couldn't mount filesystem 192.168.0.1 on /cinder
Jul 15 01:53:35 525400702875 lrmd[12685]: notice: operation_finished: fs-cinder_start_0:23692:stderr [ mount: wrong fs type, bad option, bad superblock on 192.168.0.1, ]
Jul 15 01:53:35 525400702875 lrmd[12685]: notice: operation_finished: fs-cinder_start_0:23692:stderr [        missing codepage or helper program, or other error ]
Jul 15 01:53:35 525400702875 lrmd[12685]: notice: operation_finished: fs-cinder_start_0:23692:stderr [        (for several filesystems (e.g. nfs, cifs) you might ]
Jul 15 01:53:35 525400702875 lrmd[12685]: notice: operation_finished: fs-cinder_start_0:23692:stderr [        need a /sbin/mount.<type> helper program) ]
Jul 15 01:53:35 525400702875 lrmd[12685]: notice: operation_finished: fs-cinder_start_0:23692:stderr [  ]
Jul 15 01:53:35 525400702875 lrmd[12685]: notice: operation_finished: fs-cinder_start_0:23692:stderr [        In some cases useful info is found in syslog - try ]
Jul 15 01:53:35 525400702875 lrmd[12685]: notice: operation_finished: fs-cinder_start_0:23692:stderr [        dmesg | tail or so. ]
Jul 15 01:53:35 525400702875 crmd[12688]: notice: process_lrm_event: LRM operation fs-cinder_start_0 (call=293, rc=1, cib-update=266, confirmed=true) unknown error
Jul 15 01:53:35 525400702875 crmd[12688]: notice: process_lrm_event: 525400702875.lab.eng.rdu2.redhat.com-fs-cinder_start_0:293 [ mount: wrong fs type, bad option, bad superblock on 192.168.0.1,\n       missing codepage or helper program, or other error\n       (for several filesystems (e.g. nfs, cifs) you might\n       need a /sbin/mount.<type> helper program)\n\n       In some cases useful info is found in syslog - try\n       dmesg | tail or so.\n ]

Comment 2 Hugh Brock 2014-07-16 14:21:26 UTC
In poodle 7.15.4

Comment 11 errata-xmlrpc 2014-08-04 18:35:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-1003.html


Note You need to log in before you can comment on or make changes to this bug.