Bug 1119852 - Engine remains indifferent to "Select as SPM" command
Summary: Engine remains indifferent to "Select as SPM" command
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-webadmin
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.5.0
Assignee: Liron Aravot
QA Contact: Ori Gofen
URL:
Whiteboard: storage
Depends On:
Blocks: 1093924
TreeView+ depends on / blocked
 
Reported: 2014-07-15 16:20 UTC by Ori Gofen
Modified: 2016-05-26 01:50 UTC (History)
11 users (show)

Fixed In Version: ovirt-3.5.0_rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-17 12:27:16 UTC
oVirt Team: Storage


Attachments (Terms of Use)
vdsm+engine logs (1.73 MB, application/x-gzip)
2014-07-16 07:39 UTC, Ori Gofen
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 31926 master MERGED core: ForceSelectSPM might fail Never
oVirt gerrit 32190 ovirt-engine-3.5 MERGED core: ForceSelectSPM might fail Never
oVirt gerrit 32193 ovirt-engine-3.5 MERGED core: SpmStopOnIrs - set result Never

Description Ori Gofen 2014-07-15 16:20:38 UTC
Description of problem:
Selecting a certain host as SPM is not available,UI reports vague message "Host $HOST_NAME was force selected by admin"
nothing happens

Version-Release number of selected component (if applicable):
beta

How reproducible:
100%

Steps to Reproduce:
Setup:have dc with 2 or more hosts
1.switch SPM vi UI's "Select as SPM" button

Actual results:
nothing happens but unclear UI message

Expected results:
a message on UI should be something like "switching host $HOST_NAME to be SPM"
and the command should be executed.

Additional info:

Comment 1 Ori Gofen 2014-07-15 16:27:12 UTC
Steps to Reproduce(2):
Setup:have dc with 2 or more hosts

1.maintain the SPM host

Actual results:
nothing happens but a UI message "Failed to change status of host 'vdsb' due to a failure to stop the spm."

Comment 2 Allon Mureinik 2014-07-16 02:06:01 UTC
Ori, please add engine and VDSM logs.

Comment 3 Ori Gofen 2014-07-16 07:39:24 UTC
Created attachment 918339 [details]
vdsm+engine logs

sure Alon.

Comment 4 Ori Gofen 2014-07-17 08:48:44 UTC
actually I have been mistaken regarding steps to reproduce,it seems that it is a little bit more tricky:

Steps to Reproduce:
Setup:have dc with 2 or more hosts

1.reboot the none-SPM host
2.while hosts reboot,remove dc
3.create a new dc (with domain) add the the two hosts
4.switch SPM twice

Comment 5 Liron Aravot 2014-09-03 07:40:11 UTC
This bug isn't a regression, that was happening since this new command was introduced. removing the regression keyword.

Comment 6 Ori Gofen 2014-10-01 12:19:52 UTC
verified on vt4

Comment 7 Sandro Bonazzola 2014-10-17 12:27:16 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.