Bug 1119877 - RFE: Need a single tool that deploys OSP and SW-defined backend storage(s)
Summary: RFE: Need a single tool that deploys OSP and SW-defined backend storage(s)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 5.0 (RHEL 7)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 10.0 (Newton)
Assignee: Angus Thomas
QA Contact: Yogev Rabl
URL: https://trello.com/c/ifPeoTde/125-cep...
Whiteboard:
: 1119881 (view as bug list)
Depends On: 1291943
Blocks: 1093544 1108193 1119881 1335593
TreeView+ depends on / blocked
 
Reported: 2014-07-15 17:41 UTC by arkady kanevsky
Modified: 2016-07-14 19:42 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
: 1119881 (view as bug list)
Environment:
Last Closed: 2016-07-14 19:42:04 UTC


Attachments (Terms of Use)

Description arkady kanevsky 2014-07-15 17:41:52 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 arkady kanevsky 2014-07-15 17:52:41 UTC
Current deployment via separate set of tools for Ceph and OSP causes chicken and egg dependency problem.
Ceph need OS with all packages that Ceph requires to be deployed on all nodes where Ceph to be deployed with Ceph MON service on a separate nodes from OSD ones.
In addition, Ceph requires its cluster network to be setup for OSD/storage nodes and network that ceph client will use that is also OSP storage network.

Comment 3 Mike Burns 2014-08-05 17:20:34 UTC
*** Bug 1119881 has been marked as a duplicate of this bug. ***

Comment 4 Neil Levine 2014-10-27 18:48:00 UTC
Fixed in ceph-deploy 1.5.19.

Comment 6 Neil Levine 2015-02-09 23:40:31 UTC
I think we're now converging on a single Puppet-based installer workflow for OSD and MON nodes using Red Hat Ceph Storage v1.3/Stockwell for OSP7.

Suggest the target release is updated accordingly.

Adding Federico to CC who is the product manager focused on the Ceph installer component.

Comment 8 chris alfonso 2015-07-31 17:49:54 UTC
Mike,
We've now completed the ceph integration with OSP-d. Is this RFE still relevant? If the feature has been satisfied, we'll close this RFE. please advise.

Comment 9 Mike Orazi 2015-09-14 12:52:24 UTC
I'd suggest we consider this addressed, but I would also like to ask Arkady and others to feel free to open additional bugs to track features or configuration points that are not fully covered.

Comment 10 Neil Levine 2015-12-15 22:47:15 UTC
Arkady, can we close this? 
We are tracking more granular features for Ceph in individual BZs now.

Comment 11 arkady kanevsky 2015-12-15 23:12:27 UTC
Neil,
I do not think so.
There are 2 issues.
1. There are some upstream pull requests for support of RGW on controller nodes. - But I do not see BZ for it. If one exist, please, cc me on it.

2. Current OSP-D does not support Calamari. I had not seen BZ for it either. 

Once there are BZs for them epoch BZ can be closed.

We will need a separate continues stream of BZs for OSP-D (and heat templates for it) to expose new functionality per Ceph release that should be exposed for OpenStack, especially if default config setup should be changed.
Thanks,
Arkady


Note You need to log in before you can comment on or make changes to this bug.