Bug 1119886 - Console Invocation should be set to Auto by default
Summary: Console Invocation should be set to Auto by default
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-userportal
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Frantisek Kobzik
QA Contact: Pavel Stehlik
URL:
Whiteboard: virt
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-15 18:15 UTC by Robert McSwain
Modified: 2019-04-28 10:42 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-06 13:10:17 UTC
oVirt Team: ---


Attachments (Terms of Use)

Description Robert McSwain 2014-07-15 18:15:22 UTC
Description of problem:
We have currently in Console Options -> Console Invocation set to Browser Plugin which works only on Linux. If there is options Auto it should be pre-selected by default to enable all clients using Spice console. Otherwise we have to reconfigure it each time we want to use Console for a specific VM.

Version-Release number of selected component (if applicable):
3.3.??

How reproducible:
100%

Steps to Reproduce:
1. Open Console Options -> Console Invocation
2. Observe it's defaulted to Browser rather than Auto/Native

Actual results:
Defaults to Browser

Expected results:
Default to Auto so that configuring this per VM is not required. Or allow for choosing which of these is default in the environment.

Comment 1 Frantisek Kobzik 2014-07-16 13:33:56 UTC
Hello Robert,

two questions:
1, Could you provide a screenshot of Console Options dialog of a VM that has 'browser plugin' preselected?
2, Could you tell me the value of engine option ClientModeSpiceDefault? (just run 'engine-setup -g ClientModeSpiceDefault').

Thanks.

Comment 2 Michal Skrivanek 2014-07-29 07:29:30 UTC
was this originally a pre-3.3 installation? 3.2.z had "Plugin" as the default

Comment 3 Michal Skrivanek 2014-08-05 07:57:36 UTC
(In reply to Frantisek Kobzik from comment #1)
> (just run 'engine-setup -g ClientModeSpiceDefault').

engine-config -g ClientModeSpiceDefault

Comment 5 Michal Skrivanek 2014-08-06 13:10:17 UTC
"Plugin" is a default on <3.3 installation. Since 3.4 the fresh install default is Auto
For backwards compatibility we keep former defaults so upgrades from 3.2 will retain Plugin

One can always change the global default via engine-config -s ClientModeSpiceDefault (or VNC)


Note You need to log in before you can comment on or make changes to this bug.