Bug 1119906 - [abrt] livecd-tools: yumRepo.py:1028:_getFile:NoMoreMirrorsRepoError: failure: repodata/repomd.xml from rpmfusion-free: [Errno 256] No more mirrors to try.
Summary: [abrt] livecd-tools: yumRepo.py:1028:_getFile:NoMoreMirrorsRepoError: failure...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: livecd-tools
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Brian Lane
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:0d1d3a1b4dc0712d4a26debcc43...
: 1155758 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-15 19:57 UTC by James Crawford
Modified: 2014-10-28 18:17 UTC (History)
8 users (show)

Fixed In Version: livecd-tools-21.3-1.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-28 18:17:24 UTC


Attachments (Terms of Use)
File: backtrace (4.26 KB, text/plain)
2014-07-15 19:57 UTC, James Crawford
no flags Details
File: dso_list (61 bytes, text/plain)
2014-07-15 19:57 UTC, James Crawford
no flags Details
File: environ (2.20 KB, text/plain)
2014-07-15 19:57 UTC, James Crawford
no flags Details

Description James Crawford 2014-07-15 19:57:25 UTC
Description of problem:
Looks like an error on rpmforge non free
The following is the result of grep "rpmfussion" build-log-file:

Retrieving http://download1.rpmfusion.org/free/fedora/releases/20/Everything/x86_64/os/repodata/repomd.xml ...OK
Retrieving http://download1.rpmfusion.org/free/fedora/releases/20/Everything/x86_64/os/repodata/dc91dbe015860feacd6c7e6590a3c5278e5d42076777246a6a8cad274ae30594-comps.xml.gz ...OK
Retrieving http://download1.rpmfusion.org/free/fedora/releases/20/Everything/x86_64/os/repodata/7382f8089fecf00e0178d33c6625fa932e5ecbbe0f22a53609c1ef82a73cecc9-primary.sqlite.bz2 ...OK
Retrieving http://download1.rpmfusion.org/free/fedora/updates/20/x86_64/repodata/repomd.xml ...OK
Retrieving http://download1.rpmfusion.org/free/fedora/updates/20/x86_64/repodata/33c4d5fc45defd646d88d1341ab4f1ceeede63a7a2fbf456d04c5044ade584a5-comps.xml.gz ...OK
Retrieving http://download1.rpmfusion.org/free/fedora/updates/20/x86_64/repodata/a26db6d7f695d6463ffb75d3c0b4b582525fba91dabf49fea276a1a867e3ce3e-primary.sqlite.bz2 ...OK
yum.Errors.NoMoreMirrorsRepoError: failure: repodata/repomd.xml from rpmfusion-non-free: [Errno 256] No more mirrors to try.
http://download1.rpmfusion.org/nonfree/fedora/releases/20/Everything/x86_64/os/repodata/repomd.xml: [Errno -1] Error importing repomd.xml for rpmfusion-non-free: Damaged repomd.xml file

A wget of download1.rpmfusion.org/nonfree/fedora/releases/20/Everything/x86_64/os/repodata/repomd.xml ends up with a zero length file.

Need to contact rpmfussion.org

Version-Release number of selected component:
livecd-tools-20.5-1.fc20

Additional info:
reporter:       libreport-2.2.2
cmdline:        /usr/bin/python -tt /bin/livecd-creator --config=/root/kiosk-setups/spins-ks/AZDA-kiosk-64.ks --fslabel=AZDA-Kiosk-64 --tmpdir=/var/tmp/x64 --verbose
executable:     /bin/livecd-creator
kernel:         3.15.4-200.fc20.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
#1 _getFile in /usr/lib/python2.7/site-packages/yum/yumRepo.py:1028
#2 _getFileRepoXML in /usr/lib/python2.7/site-packages/yum/yumRepo.py:1234
#3 _commonLoadRepoXML in /usr/lib/python2.7/site-packages/yum/yumRepo.py:1460
#4 _groupLoadRepoXML in /usr/lib/python2.7/site-packages/yum/yumRepo.py:1635
#5 _loadRepoXML in /usr/lib/python2.7/site-packages/yum/yumRepo.py:1661
#6 _getRepoXML in /usr/lib/python2.7/site-packages/yum/yumRepo.py:1671
#7 <lambda> in /usr/lib/python2.7/site-packages/yum/yumRepo.py:1675
#8 _check_db_version in /usr/lib/python2.7/site-packages/yum/yumRepo.py:1488
#9 _check_db_version in /usr/lib/python2.7/site-packages/yum/yumRepo.py:319
#10 populate in /usr/lib/python2.7/site-packages/yum/yumRepo.py:225

Comment 1 James Crawford 2014-07-15 19:57:27 UTC
Created attachment 918242 [details]
File: backtrace

Comment 2 James Crawford 2014-07-15 19:57:28 UTC
Created attachment 918243 [details]
File: dso_list

Comment 3 James Crawford 2014-07-15 19:57:28 UTC
Created attachment 918244 [details]
File: environ

Comment 4 Brian Lane 2014-07-15 21:09:51 UTC
Not much we can do when the repo is hosed.

Comment 5 Cristian Ciupitu 2014-08-08 14:10:24 UTC
ABRT says I've encountered the same bug. If this is really not a bug,
then ABRT should stop reporting it. In this case I think that the best
option would be to catch the error in the livecd-creator program and
exit with an non-zero status plus an error message. Uncatched exceptions
aren't nice.


ERROR message:

['/sbin/mkfs.ext3', '-F', '-L', '_Fedora-20-LiveCD-1-foo', '-m', '1', '-b', '4096', '/dev/loop2']
Traceback (most recent call last):
  File "/bin/livecd-creator", line 228, in <module>
    sys.exit(main())
  File "/bin/livecd-creator", line 211, in main
    creator.install()
  File "/usr/lib/python2.7/site-packages/imgcreate/creator.py", line 642, in install
    ayum.setup(yum_conf, self._instroot)
  File "/usr/lib/python2.7/site-packages/imgcreate/yuminst.py", line 105, in setup
    self.doTsSetup()
  File "/usr/lib/python2.7/site-packages/yum/depsolve.py", line 129, in doTsSetup
    return self._getTs()
  File "/usr/lib/python2.7/site-packages/yum/depsolve.py", line 137, in _getTs
    if not remove_only and self._tsInfo.pkgSack is None:
  File "/usr/lib/python2.7/site-packages/yum/transactioninfo.py", line 140, in <lambda>
    pkgSack = property(fget=lambda self: self._getPkgSack(),
  File "/usr/lib/python2.7/site-packages/yum/transactioninfo.py", line 137, in _getPkgSack
    self._pkgSack = self._pkgSackCtor()
  File "/usr/lib/python2.7/site-packages/yum/depsolve.py", line 76, in __call__
    return self.ayum.pkgSack
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1082, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 786, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 383, in populateSack
    sack.populate(repo, mdtype, callback, cacheonly)
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 225, in populate
    if self._check_db_version(repo, mydbtype):
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 319, in _check_db_version
    return repo._check_db_version(mdtype)
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1488, in _check_db_version
    repoXML = self.repoXML
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1675, in <lambda>
    repoXML = property(fget=lambda self: self._getRepoXML(),
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1671, in _getRepoXML
    self._loadRepoXML(text=self.ui_id)
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1661, in _loadRepoXML
    return self._groupLoadRepoXML(text, self._mdpolicy2mdtypes())
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1635, in _groupLoadRepoXML
    if self._commonLoadRepoXML(text):
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1460, in _commonLoadRepoXML
    result = self._getFileRepoXML(local, text)
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1234, in _getFileRepoXML
    size=102400) # setting max size as 100K
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1028, in _getFile
    raise Errors.NoMoreMirrorsRepoError(errstr, errors, repo=self)
yum.Errors.NoMoreMirrorsRepoError: failure: repodata/repomd.xml from development: [Errno 256] No more mirrors to try.
http://locahost:9090/repodata/repomd.xml: [Errno 14] curl#6 - "Could not resolve host: locahost"

Comment 6 Fedora Update System 2014-10-20 18:40:41 UTC
livecd-tools-21.3-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/livecd-tools-21.3-1.fc21

Comment 7 Fedora Update System 2014-10-21 17:25:45 UTC
Package livecd-tools-21.3-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing livecd-tools-21.3-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-13409/livecd-tools-21.3-1.fc21
then log in and leave karma (feedback).

Comment 8 Brian Lane 2014-10-22 19:05:03 UTC
*** Bug 1155758 has been marked as a duplicate of this bug. ***

Comment 9 Fedora Update System 2014-10-28 18:17:24 UTC
livecd-tools-21.3-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.