Bug 1119928 - Problem adding the modeshape subsystem in domain mode
Summary: Problem adding the modeshape subsystem in domain mode
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: ModeShape
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ER2
: 6.1.0
Assignee: Horia Chiorean
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-15 21:22 UTC by Thomas Hauser
Modified: 2016-02-10 08:53 UTC (History)
3 users (show)

Doc Type: Bug Fix
Doc Text:
If the user attempted to add the modeshape subsystem into a domain profile after adding it to another profile it would fail. As a result, it was impossible to add the modeshape subsystem to any profile after adding one to another profile. This has now been fixed so users can now add the subsystem to multiple profiles.
Clone Of:
Environment:
Last Closed: 2016-02-10 08:53:47 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
JBoss Issue Tracker MODE-2259 Blocker Resolved The ModeShape subsystem cannot be added via CLI to multiple profiles in domain mode 2014-07-24 18:33:55 UTC

Description Thomas Hauser 2014-07-15 21:22:16 UTC
Description of problem:
Attempting to add the modeshape subsystem into a domain profile after adding it to another profile will fail.

For example, if the user adds the modeshape subsystem into the default profile
/profile=default/subsystem=modeshape:add()

and the tries to add it to the ha profile
/profile=ha/subsystem=modeshape:add()

the following error is thrown:

    "outcome" => "failed",
    "failure-description" => {"domain-failure-description" => "JBAS014749: Operation handler failed: Service jboss.modeshape.engine is already registered"},
    "rolled-back" => true

Because of this, it is not possible through the jboss-cli to add a modeshape repository, because executing that command will complain that the subsystem hasn't been added.

See: http://pastebin.test.redhat.com/221810 for the full results.

How reproducible:
Always.

Steps to Reproduce:
1. Follow steps in description

Actual results:
It is impossible to add the modeshape subsystem to any profile after adding one to another profile.

Expected results:
Adding the modeshape subsystem to all profiles works without issue.

Comment 2 Horia Chiorean 2014-07-18 15:33:56 UTC
This has been fixed and merged in the prod branch: https://github.com/jboss-integration/modeshape/commit/fa2b69e2ec41eebfeca8dfba0a4d1a8cb5871cd5

Please note that the ModeShape related CLI scripts from code.engineering.redhat.com/ip.git have a couple of issues:

1) ModeShape-standalone.cli does not add the Infinispan cache container before creating the Infinispan caches
2) ModeShape-domain.cli does not add the ModeShape webapps to all the profiles: default & full are missing the webapps.

Comment 3 Thomas Hauser 2014-07-18 21:05:48 UTC
Hi Horia,

The infinispan cache container is added by the ModeShape-infinispan.cli script. 
The ModeShape-domain.cli also does not add the new modeshape-explorer webapp for any profile. Fixing that, nice catch, thanks!

Tom

Comment 4 Horia Chiorean 2014-07-20 05:32:44 UTC
Tom, please *don't add* the modeshape-explorer webapp. It's not being included for the product atm. and not sure it will be at all, because there are some security concerns.

I was referring to the modeshape-rest.war, modeshape-webdav.war and modeshape-cmis.war.

Comment 5 Filip Elias 2015-02-03 10:51:16 UTC
Verified in DV ER6.


Note You need to log in before you can comment on or make changes to this bug.