Bug 1119937 - extlinux.conf not updated correctly after a kernel update on arm
Summary: extlinux.conf not updated correctly after a kernel update on arm
Keywords:
Status: CLOSED DUPLICATE of bug 1088933
Alias: None
Product: Fedora
Classification: Fedora
Component: extlinux-bootloader
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dennis Gilmore
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-15 22:04 UTC by David Jones
Modified: 2014-07-16 00:46 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-16 00:46:28 UTC


Attachments (Terms of Use)

Description David Jones 2014-07-15 22:04:14 UTC
Description of problem:
Hardware: cubietruck
Arm extlinux.conf is not being correctly updated after applying kernel update.
Boots to second kernel listed.

Version-Release number of selected component (if applicable):
3.16.0-0.rc4.git1.1.fc21.armv7hl
3.16.0-0.rc4.git2.1.fc22.armv7hl
3.16.0-0.rc4.git3.1.fc22.armv7hl

How reproducible:
On each kernel update the version for the 
fdtdir /dtb-3.16.0-0.rc4.git2.1.fc21.armv7hl/ remains as the previous version number.

Steps to Reproduce:
1.Create an sdcard with old version
2.Run yum update
3.

Actual results:
# extlinux.conf generated by appliance-creator
ui menu.c32
menu autoboot Welcome to Fedora-Minimal-armhfp-rawhide-20140629. Automatic boot in # second{,s}. Press a key for options.
menu title Fedora-Minimal-armhfp-rawhide-20140629 Boot Options.
menu hidden
timeout 20
totaltimeout 600

default=Fedora (3.16.0-0.rc4.git1.1.fc21.armv7hl) 21 (Twenty One)
label Fedora (3.16.0-0.rc4.git3.1.fc22.armv7hl) 22 (Rawhide)
        kernel /vmlinuz-3.16.0-0.rc4.git3.1.fc22.armv7hl
        append ro root=UUID=47984fd6-5fcb-4547-94be-3fa261beaa75 console=ttyS0,115200 console=tty0 LANG=en_US.UTF-8
        fdtdir /dtb-3.16.0-0.rc4.git2.1.fc21.armv7hl/
        initrd /initramfs-3.16.0-0.rc4.git3.1.fc22.armv7hl.img

label Fedora (3.16.0-0.rc4.git2.1.fc22.armv7hl) 22 (Rawhide)
        kernel /vmlinuz-3.16.0-0.rc4.git2.1.fc22.armv7hl
        append ro root=UUID=47984fd6-5fcb-4547-94be-3fa261beaa75 console=ttyS0,115200 console=tty0 LANG=en_US.UTF-8
        fdtdir /dtb-3.16.0-0.rc4.git2.1.fc22.armv7hl/
        initrd /initramfs-3.16.0-0.rc4.git2.1.fc22.armv7hl.img

label Fedora (3.16.0-0.rc4.git1.1.fc21.armv7hl) 21 (Twenty One)
        kernel /vmlinuz-3.16.0-0.rc4.git1.1.fc21.armv7hl
        append ro root=UUID=47984fd6-5fcb-4547-94be-3fa261beaa75 console=ttyS0,115200 console=tty0 LANG=en_US.UTF-8
        fdtdir /dtb-3.16.0-0.rc4.git1.1.fc21.armv7hl/
        initrd /initramfs-3.16.0-0.rc4.git1.1.fc21.armv7hl.img



Expected results:
# extlinux.conf generated by appliance-creator
ui menu.c32
menu autoboot Welcome to Fedora-Minimal-armhfp-rawhide-20140629. Automatic boot in # second{,s}. Press a key for options.
menu title Fedora-Minimal-armhfp-rawhide-20140629 Boot Options.
menu hidden
timeout 20
totaltimeout 600

default=Fedora (3.16.0-0.rc4.git1.1.fc21.armv7hl) 21 (Twenty One)
label Fedora (3.16.0-0.rc4.git3.1.fc22.armv7hl) 22 (Rawhide)
        kernel /vmlinuz-3.16.0-0.rc4.git3.1.fc22.armv7hl
        append ro root=UUID=47984fd6-5fcb-4547-94be-3fa261beaa75 console=ttyS0,115200 console=tty0 LANG=en_US.UTF-8
        fdtdir /dtb-3.16.0-0.rc4.git3.1.fc22.armv7hl/
        initrd /initramfs-3.16.0-0.rc4.git3.1.fc22.armv7hl.img

label Fedora (3.16.0-0.rc4.git2.1.fc22.armv7hl) 22 (Rawhide)
        kernel /vmlinuz-3.16.0-0.rc4.git2.1.fc22.armv7hl
        append ro root=UUID=47984fd6-5fcb-4547-94be-3fa261beaa75 console=ttyS0,115200 console=tty0 LANG=en_US.UTF-8
        fdtdir /dtb-3.16.0-0.rc4.git2.1.fc22.armv7hl/
        initrd /initramfs-3.16.0-0.rc4.git2.1.fc22.armv7hl.img

label Fedora (3.16.0-0.rc4.git1.1.fc21.armv7hl) 21 (Twenty One)
        kernel /vmlinuz-3.16.0-0.rc4.git1.1.fc21.armv7hl
        append ro root=UUID=47984fd6-5fcb-4547-94be-3fa261beaa75 console=ttyS0,115200 console=tty0 LANG=en_US.UTF-8
        fdtdir /dtb-3.16.0-0.rc4.git1.1.fc21.armv7hl/
        initrd /initramfs-3.16.0-0.rc4.git1.1.fc21.armv7hl.img



Additional info:
Separate issues:- 
network does not start if /etc/sysconfig/network-scripts/ifcfg-eth0 is missing. I need to retest this with latest image.
MAC address changes after update, again need further testing.

Comment 1 Dennis Gilmore 2014-07-16 00:46:28 UTC

*** This bug has been marked as a duplicate of bug 1088933 ***


Note You need to log in before you can comment on or make changes to this bug.