Bug 1119939 - engine-config gives "No Such Entry" when entering windows 7 product key
Summary: engine-config gives "No Such Entry" when entering windows 7 product key
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-config
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Yair Zaslavsky
QA Contact: Pavel Stehlik
URL:
Whiteboard: virt
Depends On:
Blocks: 1157459
TreeView+ depends on / blocked
 
Reported: 2014-07-15 22:07 UTC by Robert McSwain
Modified: 2019-04-28 09:47 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1157459 (view as bug list)
Environment:
Last Closed: 2014-08-07 08:04:12 UTC
oVirt Team: ---


Attachments (Terms of Use)

Description Robert McSwain 2014-07-15 22:07:58 UTC
Description of problem:
[root@rhevm ~]# engine-config --set ProductKeyWindow7=XXXXX-XXXXX-XXXXX-XXXXX-XXXXX --cver=general
Error setting ProductKeyWindow7's value. No such entry with version general.


Version-Release number of selected component (if applicable):
rhevm-3.4.0-0.22.el6ev.noarch upgraded from RHEV 3.3

How reproducible:
100%

Steps to Reproduce:
1. run engine-config --set ProductKeyWindow7=XXXXX-XXXXX-XXXXX-XXXXX-XXXXX --cver=general
2. Observe the Error setting ProductKeyWindow7's value. No such entry with version general. error
3.

Actual results:
Error setting ProductKeyWindow7's value. No such entry with version general.

Expected results:
Process continues as expected 


Additional info:
This command worked under RHEVM 3.3.

The correct keys are in /etc/ovirt-engine/osinfo.conf.d/10-productkeys.properties

Comment 1 Michal Skrivanek 2014-07-16 13:06:33 UTC
keys are no longer in VdcOptions so they are not to be set via engine-config. They are now set in the osinfo properties file, which seems to be what you have done.

Does it not work then in sysprep?

Comment 2 Michal Skrivanek 2014-08-07 08:04:12 UTC
no input, closing as not a bug as the setting is to be done elsewhere in 3.4+

Comment 3 acrow 2014-10-21 19:03:59 UTC
IMHO should be re-opened as the RHEV docs don't mention this change. It's cost me about 6 hours of pointless frustration.

Alex

Comment 4 Julie 2014-10-27 09:58:48 UTC
(In reply to acrow from comment #3)
> IMHO should be re-opened as the RHEV docs don't mention this change. It's
> cost me about 6 hours of pointless frustration.
> 
> Alex

Hi Alex,
    I'm extremely sorry for the trouble you had to go through. I've opened a documentation bug for this issue[1]. 

[1]https://bugzilla.redhat.com/show_bug.cgi?id=1157459

Kind regards,
Julie


Note You need to log in before you can comment on or make changes to this bug.