Bug 1120040 - sssd 1.11.6-3.el6 fails to install
Summary: sssd 1.11.6-3.el6 fails to install
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sssd
Version: 6.6
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: alpha
: ---
Assignee: Jakub Hrozek
QA Contact: Kaushik Banerjee
URL:
Whiteboard:
: 1120066 (view as bug list)
Depends On:
Blocks: 1083985
TreeView+ depends on / blocked
 
Reported: 2014-07-16 06:35 UTC by Kaushik Banerjee
Modified: 2014-10-14 04:49 UTC (History)
10 users (show)

Fixed In Version: sssd-1.11.6-4.el6
Doc Type: Bug Fix
Doc Text:
No Documentation Needed
Clone Of:
Environment:
Last Closed: 2014-10-14 04:49:03 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1375 normal SHIPPED_LIVE sssd bug fix and enhancement update 2014-10-14 01:06:25 UTC

Description Kaushik Banerjee 2014-07-16 06:35:44 UTC
Description of problem:
sssd-1.11.6-3.el6 fails to install

Version-Release number of selected component (if applicable):
sssd-1.11.6-3.el6

How reproducible:
Always

Steps to Reproduce:
1.# yum update sssd
Loaded plugins: product-id, security, subscription-manager
Setting up Update Process
No Match for argument: ding-libs
No package ding-libs available.
Resolving Dependencies
--> Running transaction check
---> Package sssd.x86_64 0:1.11.6-1.el6 will be updated
---> Package sssd.x86_64 0:1.11.6-3.el6 will be an update
--> Processing Dependency: python-sssdconfig = 1.11.6-3.el6 for package: sssd-1.11.6-3.el6.x86_64
--> Processing Dependency: sssd-ad = 1.11.6-3.el6 for package: sssd-1.11.6-3.el6.x86_64
--> Processing Dependency: sssd-common = 1.11.6-3.el6 for package: sssd-1.11.6-3.el6.x86_64
--> Processing Dependency: sssd-common-pac = 1.11.6-3.el6 for package: sssd-1.11.6-3.el6.x86_64
--> Processing Dependency: sssd-ipa = 1.11.6-3.el6 for package: sssd-1.11.6-3.el6.x86_64
--> Processing Dependency: sssd-krb5 = 1.11.6-3.el6 for package: sssd-1.11.6-3.el6.x86_64
--> Processing Dependency: sssd-ldap = 1.11.6-3.el6 for package: sssd-1.11.6-3.el6.x86_64
--> Processing Dependency: sssd-proxy = 1.11.6-3.el6 for package: sssd-1.11.6-3.el6.x86_64
--> Running transaction check
---> Package python-sssdconfig.noarch 0:1.11.6-1.el6 will be updated
---> Package python-sssdconfig.noarch 0:1.11.6-3.el6 will be an update
---> Package sssd-ad.x86_64 0:1.11.6-1.el6 will be updated
---> Package sssd-ad.x86_64 0:1.11.6-3.el6 will be an update
--> Processing Dependency: sssd-krb5-common = 1.11.6-3.el6 for package: sssd-ad-1.11.6-3.el6.x86_64
---> Package sssd-common.x86_64 0:1.11.6-1.el6 will be updated
---> Package sssd-common.x86_64 0:1.11.6-3.el6 will be an update
--> Processing Dependency: libsss_idmap(x86-64) = 1.11.6-3.el6 for package: sssd-common-1.11.6-3.el6.x86_64
--> Processing Dependency: sssd-client(x86-64) = 1.11.6-3.el6 for package: sssd-common-1.11.6-3.el6.x86_64
--> Processing Dependency: libcollection.so.2()(64bit) for package: sssd-common-1.11.6-3.el6.x86_64
--> Processing Dependency: libini_config.so.2()(64bit) for package: sssd-common-1.11.6-3.el6.x86_64
---> Package sssd-common-pac.x86_64 0:1.11.6-1.el6 will be updated
---> Package sssd-common-pac.x86_64 0:1.11.6-3.el6 will be an update
--> Processing Dependency: libcollection.so.2()(64bit) for package: sssd-common-pac-1.11.6-3.el6.x86_64
--> Processing Dependency: libini_config.so.2()(64bit) for package: sssd-common-pac-1.11.6-3.el6.x86_64
---> Package sssd-ipa.x86_64 0:1.11.6-1.el6 will be updated
---> Package sssd-ipa.x86_64 0:1.11.6-3.el6 will be an update
--> Processing Dependency: libipa_hbac(x86-64) = 1.11.6-3.el6 for package: sssd-ipa-1.11.6-3.el6.x86_64
---> Package sssd-krb5.x86_64 0:1.11.6-1.el6 will be updated
---> Package sssd-krb5.x86_64 0:1.11.6-3.el6 will be an update
---> Package sssd-ldap.x86_64 0:1.11.6-1.el6 will be updated
---> Package sssd-ldap.x86_64 0:1.11.6-3.el6 will be an update
---> Package sssd-proxy.x86_64 0:1.11.6-1.el6 will be updated
---> Package sssd-proxy.x86_64 0:1.11.6-3.el6 will be an update
--> Processing Dependency: libcollection.so.2()(64bit) for package: sssd-proxy-1.11.6-3.el6.x86_64
--> Processing Dependency: libini_config.so.2()(64bit) for package: sssd-proxy-1.11.6-3.el6.x86_64
--> Running transaction check
---> Package libipa_hbac.x86_64 0:1.11.6-1.el6 will be updated
---> Package libipa_hbac.x86_64 0:1.11.6-3.el6 will be an update
---> Package libsss_idmap.x86_64 0:1.11.6-1.el6 will be updated
---> Package libsss_idmap.x86_64 0:1.11.6-3.el6 will be an update
---> Package sssd-client.x86_64 0:1.11.6-1.el6 will be updated
---> Package sssd-client.x86_64 0:1.11.6-3.el6 will be an update
---> Package sssd-common.x86_64 0:1.11.6-3.el6 will be an update
--> Processing Dependency: libcollection.so.2()(64bit) for package: sssd-common-1.11.6-3.el6.x86_64
--> Processing Dependency: libini_config.so.2()(64bit) for package: sssd-common-1.11.6-3.el6.x86_64
---> Package sssd-common-pac.x86_64 0:1.11.6-3.el6 will be an update
--> Processing Dependency: libcollection.so.2()(64bit) for package: sssd-common-pac-1.11.6-3.el6.x86_64
--> Processing Dependency: libini_config.so.2()(64bit) for package: sssd-common-pac-1.11.6-3.el6.x86_64
---> Package sssd-krb5-common.x86_64 0:1.11.6-1.el6 will be updated
---> Package sssd-krb5-common.x86_64 0:1.11.6-3.el6 will be an update
---> Package sssd-proxy.x86_64 0:1.11.6-3.el6 will be an update
--> Processing Dependency: libcollection.so.2()(64bit) for package: sssd-proxy-1.11.6-3.el6.x86_64
--> Processing Dependency: libini_config.so.2()(64bit) for package: sssd-proxy-1.11.6-3.el6.x86_64
--> Finished Dependency Resolution
Error: Package: sssd-common-1.11.6-3.el6.x86_64 (RHEL6)
           Requires: libini_config.so.2()(64bit)
Error: Package: sssd-common-pac-1.11.6-3.el6.x86_64 (RHEL6)
           Requires: libini_config.so.2()(64bit)
Error: Package: sssd-common-1.11.6-3.el6.x86_64 (RHEL6)
           Requires: libcollection.so.2()(64bit)
Error: Package: sssd-proxy-1.11.6-3.el6.x86_64 (RHEL6)
           Requires: libini_config.so.2()(64bit)
Error: Package: sssd-common-pac-1.11.6-3.el6.x86_64 (RHEL6)
           Requires: libcollection.so.2()(64bit)
Error: Package: sssd-proxy-1.11.6-3.el6.x86_64 (RHEL6)
           Requires: libcollection.so.2()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Actual results:
sssd 1.11.6-3.el6 fails to install

Expected results:


Additional info:

Comment 2 Jakub Hrozek 2014-07-16 11:16:34 UTC
*** Bug 1120066 has been marked as a duplicate of this bug. ***

Comment 3 Marian Ganisin 2014-07-16 12:10:20 UTC
Impact: Default installation is blocked due to this as the sssd-* packages are part of default package set.

Comment 4 Kaushik Banerjee 2014-07-16 16:05:50 UTC
Manually updated to the 1.11.6-4.el6 version

<snip>

Updated:
  libipa_hbac.x86_64 0:1.11.6-4.el6 libsss_idmap.x86_64 0:1.11.6-4.el6 python-sssdconfig.noarch 0:1.11.6-4.el6 sssd.x86_64 0:1.11.6-4.el6           
  sssd-ad.x86_64 0:1.11.6-4.el6     sssd-client.x86_64 0:1.11.6-4.el6  sssd-common.x86_64 0:1.11.6-4.el6       sssd-common-pac.x86_64 0:1.11.6-4.el6
  sssd-ipa.x86_64 0:1.11.6-4.el6    sssd-krb5.x86_64 0:1.11.6-4.el6    sssd-krb5-common.x86_64 0:1.11.6-4.el6  sssd-ldap.x86_64 0:1.11.6-4.el6      
  sssd-proxy.x86_64 0:1.11.6-4.el6 

Complete!
#

</snip>

# service sssd start
Starting sssd:                                             [  OK  ]

Comment 5 errata-xmlrpc 2014-10-14 04:49:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1375.html


Note You need to log in before you can comment on or make changes to this bug.