Bug 1120072 - Remove legacy RHS 2.0 upgrade scripts from redhat-storage-server package for RHS 3.0
Summary: Remove legacy RHS 2.0 upgrade scripts from redhat-storage-server package for ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: redhat-storage-server
Version: rhgs-3.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
: RHGS 3.0.3
Assignee: Bala.FA
QA Contact: Prasanth
URL:
Whiteboard:
Depends On:
Blocks: 1162694
TreeView+ depends on / blocked
 
Reported: 2014-07-16 08:31 UTC by Rejy M Cyriac
Modified: 2015-11-23 02:58 UTC (History)
13 users (show)

Fixed In Version: redhat-storage-server-3.0.3.1-1.el6rhs
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-15 13:38:46 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0038 normal SHIPPED_LIVE Red Hat Storage 3.0 enhancement and bug fix update #3 2015-01-15 18:35:28 UTC
Red Hat Bugzilla 1128742 None None None Never

Internal Links: 1128742

Description Rejy M Cyriac 2014-07-16 08:31:15 UTC
Description of problem:
The redhat-storage-server for RHS 3.0 installs legacy upgrade scripts in /usr/lib/glusterfs/.unsupported/ , which came over from RHS 2.0

rhs_upgrade.py  rhs_upgrade.pyc  rhs_upgrade.pyo

1) These upgrade scripts are not relevant for RHS 3.0.

2) Their presence in the redhat-storage-server package for RHS 3.0 means that they would replace the more relevant upgrade scripts made avaiable through RHS 2.1U4, on an upgrade to RHS 3.0 .

3) These legacy upgrade scripts are based on RHN subscription, and may cause issues if run on RHS 3.0 which is based on newer RHSM/CDN.

If any upgrade scripts are to be shipped with the redhat-storage-server package for RHS 3.0, it should be the newer more relevant version made available for RHS 2.1U4

Version-Release number of selected component (if applicable):
redhat-storage-server-3.0.0.0-5.el6rhs

How reproducible:


Steps to Reproduce:
1.Install RHS 3.0
2.Observe presence of rhs_upgrade.py, rhs_upgrade.pyc, rhs_upgrade.pyo scripts in /usr/lib/glusterfs/.unsupported/
3.Examine /usr/lib/glusterfs/.unsupported/rhs_upgrade.py

Actual results:
The redhat-storage-server for RHS 3.0 installs legacy upgrade scripts in /usr/lib/glusterfs/.unsupported/ , which came over from RHS 2.0 

Expected results:
Legacy upgrade scripts from RHS 2.0 are not to be present in RHS 3.0 .
If any upgrade scripts are to be shipped with the redhat-storage-server package for RHS 3.0, it should be the newer more relevant version made available for RHS 2.1U4

Comment 4 Bala.FA 2014-10-21 14:03:33 UTC
Patch is under review at https://code.engineering.redhat.com/gerrit/35210

Comment 5 Prasanth 2015-01-07 10:03:30 UTC
Verified in redhat-storage-server-3.0.3.4-1.el6rhs.noarch

Legacy upgrade scripts from RHS 2.0 are not present in RHS 3.0u3

######
[root@snow .unsupported]# cat /etc/redhat-storage-release 
Red Hat Storage Server 3.0 Update 3

[root@snow .unsupported]# pwd
/usr/lib/glusterfs/.unsupported

[root@snow .unsupported]# ls -al
total 32
drwxr-xr-x. 4 root root  4096 Jan  7 12:08 .
drwxr-xr-x. 3 root root  4096 Jan  7 12:08 ..
drwxr-xr-x. 7 root root  4096 Jan  7 12:08 gluster-deploy-0.8
drwxr-xr-x. 2 root root  4096 Jan  7 12:08 gtop-1.0
-rwxr-xr-x. 1 root root 13496 Dec 27 18:31 rhs-system-init.sh
######

Comment 6 Shalaka 2015-01-09 09:52:31 UTC
Hi Bala,

Please add doc text for this bug.

Comment 9 errata-xmlrpc 2015-01-15 13:38:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0038.html


Note You need to log in before you can comment on or make changes to this bug.