Bug 1120085 - operating system name rendered as HTML
Summary: operating system name rendered as HTML
Keywords:
Status: CLOSED DUPLICATE of bug 1106417
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Ohad Levy
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-16 08:55 UTC by Sachin Ghai
Modified: 2014-07-16 09:03 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-16 09:03:00 UTC


Attachments (Terms of Use)
os name rendered as HTML. Name displayed as Heading (25.06 KB, image/png)
2014-07-16 08:55 UTC, Sachin Ghai
no flags Details

Description Sachin Ghai 2014-07-16 08:55:28 UTC
Created attachment 918353 [details]
os name rendered as HTML. Name displayed as Heading

Description of problem:
I was trying to validate 'New Operating system' form and found that when we enter OS name with HTML tags then it is rendered as HTML.

I tried with heading tag: <h1>SGHAI</h1>

After creating os, the name is rendered as html heading.  

Version-Release number of selected component (if applicable):

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.19-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.19-1.el6_5.noarch
* candlepin-tomcat6-0.9.19-1.el6_5.noarch
* elasticsearch-0.90.10-4.el6sat.noarch
* foreman-1.6.0.21-1.el6sat.noarch
* foreman-compute-1.6.0.21-1.el6sat.noarch
* foreman-gce-1.6.0.21-1.el6sat.noarch
* foreman-libvirt-1.6.0.21-1.el6sat.noarch
* foreman-ovirt-1.6.0.21-1.el6sat.noarch
* foreman-postgresql-1.6.0.21-1.el6sat.noarch
* foreman-proxy-1.6.0.9-1.el6sat.noarch
* foreman-selinux-1.6.0-5.el6sat.noarch
* foreman-vmware-1.6.0.21-1.el6sat.noarch
* katello-1.5.0-26.el6sat.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.5-1.el6sat.noarch
* katello-installer-0.0.53-1.el6sat.noarch
* openldap-2.4.23-32.el6_4.1.x86_64
* pulp-katello-0.3-3.el6sat.noarch
* pulp-nodes-common-2.4.0-0.23.beta.el6sat.noarch
* pulp-nodes-parent-2.4.0-0.23.beta.el6sat.noarch
* pulp-puppet-plugins-2.4.0-0.23.beta.el6sat.noarch
* pulp-puppet-tools-2.4.0-0.23.beta.el6sat.noarch
* pulp-rpm-plugins-2.4.0-0.23.beta.el6sat.noarch
* pulp-selinux-2.4.0-0.23.beta.el6sat.noarch
* pulp-server-2.4.0-0.23.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el6sat.noarch
* rubygem-hammer_cli-0.1.1-5.el6sat.noarch
* rubygem-hammer_cli_foreman-0.1.1-9.el6sat.noarch
* rubygem-hammer_cli_foreman_tasks-0.0.3-2.el6sat.noarch
* rubygem-hammer_cli_katello-0.0.4-7.el6sat.noarch
How reproducible:
always

Steps to Reproduce:
1. create operating system with name <h1>SGHAI</h1>
2.
3.

Actual results:
OS name rendered as HTML

Expected results:
It should be created and displayed with name <h1>SGHAI</h1>.

Additional info:

Comment 1 Sachin Ghai 2014-07-16 08:55:56 UTC
Will check other entities too.

Comment 2 Daniel Lobato Garcia 2014-07-16 09:03:00 UTC
This seems to be a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1106417 which has been recently fixed.

*** This bug has been marked as a duplicate of bug 1106417 ***


Note You need to log in before you can comment on or make changes to this bug.