Bug 1120087 - Disk format doesn't change back to the original after being imported with collapse snapshot
Summary: Disk format doesn't change back to the original after being imported with col...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.5.0
Assignee: Tal Nisan
QA Contact: Carlos Mestre González
URL:
Whiteboard: storage
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-16 08:59 UTC by Carlos Mestre González
Modified: 2016-02-10 17:54 UTC (History)
13 users (show)

Fixed In Version: vt3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-22 07:59:19 UTC
oVirt Team: Storage


Attachments (Terms of Use)
Engine log disk id is "710a1b29-5037-435e-8f38-44edc78dc175" (140.28 KB, text/x-log)
2014-07-16 09:03 UTC, Carlos Mestre González
no flags Details

Description Carlos Mestre González 2014-07-16 08:59:20 UTC
Description of problem:
VM's disk format always is imported as thin provisioning with collapse snapshot (RAW sparse)

Version-Release number of selected component (if applicable):
av10.1 - rhevm-3.4.1-0.25.el6ev.noarch.rpm

How reproducible:
100%

Steps to Reproduce:
1. Create a vm with prealloacted policy (RAW no sparse)
2. Add a snapshot
3. Export the vm
4. remove the original vm
5. Import the vm with collapse snapshot

Actual results:
Imported vm's disk is thin provisioning (cow sparse)

Expected results:
Imported Vm's disk is the original format, preallocated.


Additional info:
Tested for Virtio and IDE interfaces.

Comment 1 Carlos Mestre González 2014-07-16 09:03:07 UTC
Created attachment 918355 [details]
Engine log disk id is "710a1b29-5037-435e-8f38-44edc78dc175"

Comment 2 Allon Mureinik 2014-07-17 06:34:10 UTC
What storage was it created on, exported to and imported to?
(I'm not clear what the "on nfs" in the title refers to)

Comment 3 Allon Mureinik 2014-09-03 08:33:49 UTC
Tal, doesn't the fix for bug 1130761 cover this issue too?

Comment 4 Tal Nisan 2014-09-10 10:38:20 UTC
Followed all steps to reproduce in 3.5RC, imported to an NFS domain and the result was a RAW sparse disk as it should.
Note that when importing to a block domain the type will be change to COW since block domain does not support RAW sparse disks by design.

Comment 5 Eyal Edri 2014-09-10 21:29:03 UTC
bug fixed in vt3.
if you think it's not included in latest build, please contact rhev-integ@redhat.com


Note You need to log in before you can comment on or make changes to this bug.