Bug 1120183 - avc: denied { write } for comm="prelink" for /var/lock/subsys/rhsmcertd and /var/log/rhsm/rhsm.log
Summary: avc: denied { write } for comm="prelink" for /var/lock/subsys/rhsmcertd an...
Keywords:
Status: CLOSED DUPLICATE of bug 1103674
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: prelink
Version: 6.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Jakub Jelinek
QA Contact: qe-baseos-tools
URL:
Whiteboard:
Depends On:
Blocks: 1083985
TreeView+ depends on / blocked
 
Reported: 2014-07-16 11:11 UTC by Alexander Todorov
Modified: 2014-07-16 11:22 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-16 11:22:40 UTC


Attachments (Terms of Use)

Description Alexander Todorov 2014-07-16 11:11:27 UTC
Description of problem:

time->Tue Jul 15 18:47:02 2014
type=SYSCALL msg=audit(1405464422.886:25): arch=c000003e syscall=59 success=yes exit=0 a0=1dbce70 a1=1dbcea0 a2=7fff230c2510 a3=19 items=0 ppid=7271 pid=7272 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="prelink" exe="/usr/sbin/prelink" subj=system_u:system_r:prelink_mask_t:s0 key=(null)
type=AVC msg=audit(1405464422.886:25): avc:  denied  { append } for  pid=7272 comm="prelink" path="/var/log/rhsm/rhsm.log" dev=dm-0 ino=1048628 scontext=system_u:system_r:prelink_mask_t:s0 tcontext=system_u:object_r:rhsmcertd_log_t:s0 tclass=file
type=AVC msg=audit(1405464422.886:25): avc:  denied  { write } for  pid=7272 comm="prelink" path="/var/lock/subsys/rhsmcertd" dev=dm-0 ino=1050395 scontext=system_u:system_r:prelink_mask_t:s0 tcontext=system_u:object_r:rhsmcertd_lock_t:s0 tclass=file


Filing against prelink b/c IMO it doesn't have to access these files which belong to subscription-manager and are not ELF objects.

Comment 1 Alexander Todorov 2014-07-16 11:22:40 UTC

*** This bug has been marked as a duplicate of bug 1103674 ***


Note You need to log in before you can comment on or make changes to this bug.