Bug 1120185 - Thrown IndexError: list index out of range when using "ovirt-node-config h"
Summary: Thrown IndexError: list index out of range when using "ovirt-node-config h"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.5.0
Assignee: Douglas Schilling Landgraf
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On: rebase-ovirt-node-3.1 1118962
Blocks: rhevh-7.0
TreeView+ depends on / blocked
 
Reported: 2014-07-16 11:15 UTC by haiyang,dong
Modified: 2016-02-10 20:10 UTC (History)
20 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1118962
Environment:
Last Closed: 2015-02-11 20:59:47 UTC
oVirt Team: Node


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC
oVirt gerrit 29978 None None None Never

Description haiyang,dong 2014-07-16 11:15:08 UTC
+++ This bug was initially created as a clone of Bug #1118962 +++

Description of problem:
when using "ovirt-node-config h" to get more information how to use "ovirt-node-config" tools 
failed with follow error info:
[root@dhcp-66-73-241 admin]# ovirt-node-config h
Traceback (most recent call last):
  File "/usr/bin/ovirt-node-config", line 94, in <module>
    cls, func = split_clsfunc(args[1])
IndexError: list index out of range
[root@dhcp-66-73-241 admin]# ovirt-node-config help
Traceback (most recent call last):
  File "/usr/bin/ovirt-node-config", line 94, in <module>
    cls, func = split_clsfunc(args[1])
IndexError: list index out of range

Version-Release number of selected component (if applicable):
ovirt-node-iso-3.5.0.ovirt35.20140707.el6.iso

How reproducible:
100%


Steps to Reproduce:


Actual results:


Expected results:


Additional info:

Comment 1 haiyang,dong 2014-07-16 11:15:29 UTC
This issue could reproduce in the follow version:
ovirt-node-3.1.0-0.5.20140711git7197118.el7.noarch.rpm
rhev-hypervisor7-7.0-20140714.0.iso

so need clone from upstream to track it in rhevh 7

Comment 2 Douglas Schilling Landgraf 2014-07-22 01:19:56 UTC
Hello Fabian,

Should we move this one to MODIFIED? Next rebase should include this fix.

Comment 3 Fabian Deutsch 2014-07-22 08:40:06 UTC
I'll move this to modified once this lands in our d/s codebase. Which happens with the rebase, before that I'll keep it in post.

Comment 4 haiyang,dong 2014-10-17 07:38:17 UTC
Test version:
rhev-hypervisor7-7.0-20141006.0.el7ev
ovirt-node-3.1.0-0.20.20141006gitc421e04.el7.noarch.rpm

Test steps:
[root@localhost admin]# ovirt-node-config h
Usage: ovirt-node-config [options] help|run [<CLASS>[.<FUNC> [<ARG> [<ARG>] ...]]]]

Options:
  -h, --help            show this help message and exit
  -m MODULE, --module=MODULE
                        Module to use
  --dry                 Enable dry mode
  --config=CFGFILE      Config file to use

Available classes in module 'ovirt.node.config.defaults':
- Collectd
- ConfigVersion
- Hostname
- IPv6
- Installation
- KDump
- Keyboard
- Logrotate
- Management
- NFSv4
- Nameservers
- Netconsole
- Network
- NetworkLayout
- NicBonding
- NodeConfigFileSection
- RuntimeImageState
- SCSIDhAlua
- SSH
- Syslog
- Timeservers
- iSCSI

Not thrown IndexError: list index out of range when using "ovirt-node-config h" now. so this bug has been fixed, change the status into "VERIFIED".

Comment 7 errata-xmlrpc 2015-02-11 20:59:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.