Bug 1120232 - Taking snapshot of vm in suspend state doesn't work
Summary: Taking snapshot of vm in suspend state doesn't work
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.6.0
Assignee: Michal Skrivanek
QA Contact: Israel Pinto
URL:
Whiteboard: virt
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-16 13:37 UTC by Raz Tamir
Modified: 2016-02-10 19:48 UTC (History)
10 users (show)

Fixed In Version: ovirt-engine-3.6.0-0.0.master.20150412172306.git55ba764
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-04 11:20:55 UTC
oVirt Team: Virt


Attachments (Terms of Use)
vdsm and engine logs (1.44 MB, application/x-gzip)
2014-07-16 13:37 UTC, Raz Tamir
no flags Details
vdsm and engine logs (2.12 MB, application/x-gzip)
2014-08-17 07:50 UTC, Raz Tamir
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 34731 master MERGED core: don't allow snapshot for suspended vm Never

Description Raz Tamir 2014-07-16 13:37:07 UTC
Created attachment 918410 [details]
vdsm and engine logs

Description of problem:
Setup:
1 vm with OS.
Creating new file on vm and suspend it. When in suspend state, take snapshot.
After snapshot operation complete, delete the file and preview.
The expected result is that  the file will be found on the vm's disk.
The file is not fount in the vm's disk


Version-Release number of selected component (if applicable):
ovirt-engine-3.5.0-0.0.master.20140629172257.git0b16ed7.el6.noarch
vdsm-4.16.0-3.git601f786.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. explained above
2.
3.

Actual results:


Expected results:
The file should be restore after previewing the snapshot

Additional info:

Comment 1 Tal Nisan 2014-07-17 06:09:29 UTC
Raz, how is it an automation blocker?

Comment 2 Raz Tamir 2014-07-17 06:36:46 UTC
It should be Regression not automation blocker.

Comment 3 Michal Skrivanek 2014-08-15 13:55:50 UTC
I have a hard time finding anything in the noise of vdsm. Would it be possible to retry, as there are several issues in the log already addressed in recent 3.5 builds

Comment 4 Raz Tamir 2014-08-17 07:50:42 UTC
Created attachment 927420 [details]
vdsm and engine logs

Comment 5 Michal Skrivanek 2014-08-22 10:31:39 UTC
still quite a noise…which version did you use for comment #4?
I don't see any issues so far

decreasing severity as easy workaround exists

Comment 6 Raz Tamir 2014-08-22 11:08:06 UTC
Hi Michal,
What do you expect to see?
I wrote in the description that the issue is that the file that was part of the isn't restored after we delete the file and and preview.
In logs all is good.
So I think the severity should be urgent since this basic operation could cause a data loss

Comment 7 Omer Frenkel 2014-09-01 09:03:11 UTC
Ok thanks to Raz i got this reproduced, 
i think we already seen a similar issue before, 
the problem is that when resuming from hibernation, vdsm is using the saved configuration file to start the vm, in this file, the volume id is the previous snapshot volume, and vdsm ignore the new snapshot volume id sent from the engine.

this means that the vm is still using the previous snapshot, and only after fresh restart the vm will use the new snapshot.

not sure if we need to fix vdsm to handle this situation, or just decide to block snapshot for suspended vm

also, i dont think this is a regression, Raz, did this flow ever worked?

Comment 8 Raz Tamir 2014-09-01 09:12:14 UTC
Hi Omer,
According to previous test runs it used to work

Comment 9 Omer Frenkel 2014-09-02 11:00:05 UTC
removing regression flag, i verified the same behaviour in 3.4 
please let me know if you are able to see this working on previous version.

since we dont have hibernation information saved in the snapshot (ovf) i am in favor of blocking snapshot for suspended vm.
Michal what do you think?

Comment 10 Michal Skrivanek 2014-10-31 11:30:05 UTC
(In reply to Omer Frenkel from comment #9)
+1

Comment 11 Israel Pinto 2015-09-09 09:45:44 UTC
Verify with:
Engine RHEVM: 3.6.0-0.13.master.el6
VDSM: vdsm-4.17.5-1.el7ev

Scenario:
1. Create VM with OS
2. Run VM
3. Suspend VM
4. Take snapshot on this VM
Results:
Operation canceled with message:
"Cannot create Snapshot because the VM is in Suspended status"

Test PASS

Comment 13 Sandro Bonazzola 2015-11-04 11:20:55 UTC
oVirt 3.6.0 has been released on November 4th, 2015 and should fix this issue.
If problems still persist, please open a new BZ and reference this one.


Note You need to log in before you can comment on or make changes to this bug.