Bug 1120239 - Unprocessable entity OsParameter (id: new):
Summary: Unprocessable entity OsParameter (id: new):
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: foreman
Version: 5.0 (RHEL 7)
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: ga
: Installer
Assignee: Marek Hulan
QA Contact: Ami Jeain
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-16 13:54 UTC by Dan Radez
Modified: 2016-04-26 18:46 UTC (History)
5 users (show)

Fixed In Version: foreman-1.6.0.21-2.el6ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-21 18:05:28 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1090 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Enhancement Advisory 2014-08-22 15:28:08 UTC

Description Dan Radez 2014-07-16 13:54:09 UTC
Description of problem:
API call is made from ofi to foreman to seed the database. When the Subscription manager data is passed foreman throws Unprocessable entity OsParameter (id: new):

Version-Release number of selected component (if applicable):


How reproducible:
every time

Steps to Reproduce:
1. Run OFI and add subscription manager creds
2.
3.

Actual results:
422 error from foreman


Expected results:
successful seed.

Additional info:
Discussed this mhulan in irc, he pointed to an upstream bug
https://github.com/theforeman/foreman/pull/1567
that probably needs to be cherry picked into our foreman for a short term fix

Comment 4 Ami Jeain 2014-08-07 12:52:30 UTC
not seeing the error while testing Staypuft installer

Comment 5 errata-xmlrpc 2014-08-21 18:05:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1090.html


Note You need to log in before you can comment on or make changes to this bug.