Bug 112024 - no korean keyboard
no korean keyboard
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rhpl (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-12 17:43 EST by Dimitri Papadopoulos
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-08 15:37:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot showing absence of "Korean" keyboard (13.49 KB, image/png)
2003-12-12 17:43 EST, Dimitri Papadopoulos
no flags Details
photograph of a Korean keyboard (58.24 KB, image/jpeg)
2003-12-12 17:46 EST, Dimitri Papadopoulos
no flags Details
Korean keyboard in Keyboard Layout Switcher (431.94 KB, image/png)
2003-12-22 02:53 EST, sangu
no flags Details
KDE Control Center lacks Korean keyboard layout (33.33 KB, image/png)
2004-01-10 08:37 EST, Dimitri Papadopoulos
no flags Details

  None (edit)
Description Dimitri Papadopoulos 2003-12-12 17:43:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007

Description of problem:
I'm not sure this is really related to redhat-config-keyboard, could
be related to XFree86. In any case there's no support for Koren
keyboards. There's no "Korean" or "Hangul" choice as you can see on
the attached photograph.


Version-Release number of selected component (if applicable):
redhat-config-keyboard-1.1.5-2

How reproducible:
Always

Steps to Reproduce:
1. Run redhat-config-keyboard
2. Look at the list of keyboards


Actual Results:  No "Korean" item in the list.


Expected Results:  Presence of "Korean" item in the list.


Additional info:
Comment 1 Dimitri Papadopoulos 2003-12-12 17:43:47 EST
Created attachment 96507 [details]
screenshot showing absence of "Korean" keyboard
Comment 2 Dimitri Papadopoulos 2003-12-12 17:46:56 EST
Created attachment 96508 [details]
photograph of a Korean keyboard
Comment 3 Brent Fox 2003-12-15 12:06:08 EST
Can you tell me what the correct XFree86 keymap for Korean keyboards is?

I'm cc'ing mharris on this in case he knows.
Comment 4 Dimitri Papadopoulos 2003-12-15 14:03:56 EST
Hi,

I'm not very proficient in X11 internals, I just need to be able to
set up a Korean keyboard for my wife, on a computer that's otherwise
using an English, French or Greek system-wide default locale.

Actually I think the XFree86 keymap for Korean keyboards is already
part of Fedora:
	/usr/share/xmodmap/xmodmap.kr
The main difference between my Korean keyboard and a US keyboard are
the Hangul key (labelled Han/Yong) for switching between Korean and
English alphabet and the Hangul_Hanja key (labelled Hanja) for
switching between Korean and Chinese alphabet.

When in Korean mode, I understand a XIM is needed for input, as the
basic units of Korean text are syllabes (aka. jamos, made of two or
three letters). Syllabes are entered by typing each letter
sequentially, and they change their appearance while being typed.
However I'm not messing with XIM yet, I just need to declare somewhere
I'm using a Korean keyboard.

Some background information on Korean from:

	http://x.holovko.ru/Xlib/chap13.html

	Korean also has a phonetic symbol set, called Hangul.
	Each of the 24 basic phonetic symbols (14 consonants
	and 10 vowels) represents a specific sound. A syllable
	is composed of two or three parts: the initial consonants,
	the vowels, and the optional last consonants. With Hangul,
	syllables can be treated as the basic units on which text
	processing is done. For example, a delete operation may
	work on a phonetic symbol or a syllable. Korean code sets
	include several thousands of these syllables. A user types
	the phonetic symbols that make up the syllables of the
	words to be entered. The display may change as each
	phonetic symbol is entered. For example, when the second
	phonetic symbol of a syllable is entered, the first
	phonetic symbol may change its shape and size. Likewise,
	when the third phonetic symbol is entered, the first two
	phonetic symbols may change their shape and size.

	http://docs.sun.com/db/doc/806-6642/6jfipqu52?a=view

	Korean text can be written using a phonetic writing
	system called Hangul. Hangul has more than 11,000
	characters, which consist of consonants and vowels
	known as jamos. About 3000 characters from the entire
	Hangul vocabulary of characters are usually used in
	Korean computer systems. Korean also uses ideographs
	based on the set invented in China, called hanja.
	Korean text requires over 6000 hanja characters.
	Hanja is used mostly to avoid confusion when Hangul
	would be ambiguous. Hangul characters are formed by
	combining consonants and vowels. After combining them,
	they can compose one syllable, which is a Hangul
	character. Hangul characters are often arranged in
	a square, so that the group takes up the same space
	as a hanja character. Arabic numerals, Roman letters,
	and special symbol characters are also present in
	Korean text.

See also:
	http://users.linuxbourg.ch/ricky/korean.html
Comment 5 sangu 2003-12-22 02:49:16 EST
Gnome Applet 2.4.x's keyboard Layout Switcher(gkb-applet-2) has Korea
Keyboard.
Comment 6 sangu 2003-12-22 02:53:39 EST
Created attachment 96663 [details]
Korean keyboard in Keyboard Layout Switcher
Comment 7 Brent Fox 2004-01-08 14:28:03 EST
Ok, I've talked to some other people and I have a little better idea
of what's going on here.  You don't really need a Korean keymap
selected.  A US keymap will do just fine.  What you do need to do is
make sure that the locale is set to Korean.

To do this, you need to have installed Korean language support in the
Anaconda language support screen.  Then when you log in with GDM, make
sure you pick Korean as the language.

Once you log in, then you can switch between the US and Korean input
methods by pressing <Shift>Space.  This works for me on my test
machine.  Can you try this and see if it works for you?

One thing I can do is to add an entry for Korean keyboards although
all it will do is load a US keymap.  I believe that XFree86 keys off
of the locale to figure out which input methods to enable.
Comment 8 Dimitri Papadopoulos 2004-01-08 15:05:27 EST
I totally agree with the last paragraph. Please add a Korean entry,
even if it's just a US alias. Here's a brief explanation why this is
needed.

I understand I don't necessarily need a Korean keymap. However these
are interbal issues. As an end-user, I see that I have a Korean
keyboard, period. Then I look for such a keyboard in the list of
keyboards and can't find it. That's disturbing.

Also Microsoft Windows does have a Korean keyboard entry.

Finally how is the Korean keyboard different from a Japanese keyboard?
I'm not talking about X11 internals. I'm talking about the layout of
the hardware and the way it's used. From what I know, Japanase and
Korean are used in a similar way. So I can see no reason why there
should be a Japanase entry and no Korean entry. Again I'm not talking
about internals. Maybe I'm missing some difference in the way Japanase
and Korean keyboards are used.
Comment 9 Brent Fox 2004-01-08 15:29:35 EST
Changing component to rhpl since that's where the list of keyboards
comes from.
Comment 10 Brent Fox 2004-01-08 15:37:10 EST
Ok, I've added a Korean keyboard entry to the keyboard list and
committed it to cvs.  This should fix the problem.  Note that the user
will still have to know to use <Shift> Space to switch between methods.
Comment 11 Dimitri Papadopoulos 2004-01-10 07:21:09 EST
The user shouldn't have to know to use <Shift> Space to switch between
methods. That's what the Hangul and Hangul_Hanja keys are for. The
user _could_ use <Shift> Space but shouldn't _have_ to.

Are you sure the Korean keymap isn't a little bit different from the
US keymap, just to take into account these two keys?
Comment 12 Dimitri Papadopoulos 2004-01-10 08:19:21 EST
Otherwise I did have US-English, French, German, Greek, and Korean
language support installed. For example Korean man pages are installed:
	$ rpm -qa | fgrep man-pages-
	man-pages-1.60-4
	man-pages-fr-0.9.7-8
	man-pages-ko-1.48-10
	man-pages-de-0.4-6
	$ 

I picked up Korean language in GDM prior to logging in. I'm now able
to switch from English input to Korean input using <Shift> Space. That
said the  input method doesn't seem to work very well, at least under
KDE. Using the Kate text editor, I'm unable to see what I'm typing in
Korean. I have to switch back to English input to see the Korean text
that has been typed. Anyway, that's another unrelated issue.

Note that I have not been able yet to check whether the Hangul and
Hangul_Hanja keys work properly and switch input methods under a
Korean locale. The Korean keyboard is on a Windows machine now, I'll
try again later.

Finally, it's not convenient to have to log under a Korean locale to
type Korean text. This is especially true now that Red Hat is moving
to UTF-8 locales. I'm currently working under a French locale, but
sometimes I want to search the Greek Yellow Pages, or search for a
Korean word in Google. Windows allows many input methods / keyboard
layouts under the French locale, and I find that very convenient. I
realize this is probably a X11 limitation / bug, however it would be
nice if an issue could be opened somewhere so that this gets a chance
to be fixed someday. Anyway, that's yet another unrelated issue.
Comment 13 Dimitri Papadopoulos 2004-01-10 08:34:56 EST
Also note that the KDE Control Center also lacks a Korean keyboard.
See attached screenshot. I'm not sure whether this is related. Was the
KDE Control Center modified to take its information from:
/usr/lib/python2.2/site-packages/rhpl/keyboard_models.py
or did KDE forget to add a Korean item to the list as well?
Comment 14 Dimitri Papadopoulos 2004-01-10 08:37:09 EST
Created attachment 96875 [details]
KDE Control Center lacks Korean keyboard layout

Note You need to log in before you can comment on or make changes to this bug.