Bug 1120252 - Unable to start vlan interface
Summary: Unable to start vlan interface
Keywords:
Status: CLOSED DUPLICATE of bug 1116394
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: initscripts
Version: 6.6
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: rc
: ---
Assignee: Lukáš Nykrýn
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks: 1174739
TreeView+ depends on / blocked
 
Reported: 2014-07-16 14:26 UTC by Robin Hack
Modified: 2016-11-25 13:05 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1174739 (view as bug list)
Environment:
Last Closed: 2014-07-22 14:12:30 UTC


Attachments (Terms of Use)

Description Robin Hack 2014-07-16 14:26:49 UTC
Description of problem:
Hi. I'm not able to start my vlan interface.

My configuration:
# cat ifcfg-vlan178 
DEVICE=vlan178
VLAN=yes
VLAN_NAME_TYPE=VLAN_PLUS_VID_NO_PAD
PHYSDEV=em1
BOOTPROTO=static
ONBOOT=yes
BRIDGE=br0_vlan178


Version-Release number of selected component (if applicable):
initscripts-9.03.45-1.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. Create ifcfg-vlan178 as I suggested.
2. # ifup vlan178
3.

Actual results:
# ifup vlan178
Error: argument "178:" is wrong: id is invalid
ERROR: could not add vlan 178: as vlan178 on dev em1


Expected results:
Something beautiful... or just vlan178 interface up and running.

Additional info:

Comment 1 Lukáš Nykrýn 2014-07-22 13:52:33 UTC
Damn it there is one more typo

diff --git a/sysconfig/network-scripts/ifup b/sysconfig/network-scripts/ifup
index 189fcce..7dc349a 100755
--- a/sysconfig/network-scripts/ifup
+++ b/sysconfig/network-scripts/ifup
@@ -86,7 +86,7 @@ if [ "${VLAN}" = "yes" ] && [ "$ISALIAS" = "no" ] && [ -n $DEVICE ]; then
         fi
         MATCH='^vlan[0-9]{1,4}?'
          if [[ "${DEVICE}" =~ $MATCH ]]; then
-             VID=$(echo "${DEVICE}" | LC_ALL=C sed 's/^vlan0*//'):
+             VID=$(echo "${DEVICE}" | LC_ALL=C sed 's/^vlan0*//')
              # PHYSDEV should be set in ifcfg-vlan* file
              if test -z "$PHYSDEV"; then
                 net_log $"PHYSDEV should be set for device ${DEVICE}"

Comment 2 Robin Hack 2014-07-22 14:08:05 UTC
(In reply to Lukáš Nykrýn from comment #1)
> Damn it there is one more typo
Thanks for fix. It works for me.

Comment 3 Lukáš Nykrýn 2014-07-22 14:12:30 UTC
Lets put it under the previous typo in vlan bug.

*** This bug has been marked as a duplicate of bug 1116394 ***


Note You need to log in before you can comment on or make changes to this bug.