Bug 1120273 - ocaml-cil-1.7.3-6.fc22 FTBFS: cilly.native does not halt
Summary: ocaml-cil-1.7.3-6.fc22 FTBFS: cilly.native does not halt
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: ocaml-cil
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard W.M. Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-16 15:24 UTC by Petr Pisar
Modified: 2014-07-21 12:15 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-21 12:15:48 UTC


Attachments (Terms of Use)
Patch to fix unsafe use of Obj.magic (502 bytes, patch)
2014-07-16 15:34 UTC, Gabriel Kerneis
no flags Details | Diff

Description Petr Pisar 2014-07-16 15:24:17 UTC
ocaml-cil-1.7.3-6.fc22 fails to build on x86_64 for me because it never finishes. It busy-cycles in cilly.native command. I had to kill a mock job after 15 hours. Provided the koji build takes 12 minutes normally, something is wrong in the compiler probably. Here <http://koji.fedoraproject.org/koji/taskinfo?taskID=7151385> you can see a scratch build.

Comment 1 Gabriel Kerneis 2014-07-16 15:34:10 UTC
Created attachment 918456 [details]
Patch to fix unsafe use of Obj.magic

Thanks for the report. This is a known bug fixed upstream, but I did not realize it was the cause for the current failure. Patch attached.

Comment 2 Richard W.M. Jones 2014-07-21 12:15:48 UTC
Thanks for the patch.  I have added this to the CIL package
in Fedora and will push & build it shortly.


Note You need to log in before you can comment on or make changes to this bug.