Bug 1120288 - Rubygem-staypuft: While HA deployment we must ensure that one of the nodes has rabbit running before starting it on other nodes.
Summary: Rubygem-staypuft: While HA deployment we must ensure that one of the nodes ha...
Keywords:
Status: CLOSED DUPLICATE of bug 1122314
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-foreman-installer
Version: 5.0 (RHEL 7)
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: ga
: Installer
Assignee: John Eckersberg
QA Contact: Leonid Natapov
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-16 16:09 UTC by Leonid Natapov
Modified: 2016-04-27 00:37 UTC (History)
6 users (show)

Fixed In Version: openstack-foreman-installer-2.0.16-1.el6ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-19 20:26:04 UTC


Attachments (Terms of Use)
rabbitmq log (1.18 MB, text/plain)
2014-07-16 16:09 UTC, Leonid Natapov
no flags Details

Description Leonid Natapov 2014-07-16 16:09:38 UTC
Created attachment 918460 [details]
rabbitmq log

HA deployment has failed because rabbit failed to start. Looks like the node it was trying to cluster with was only half up or something. While HA deployment we must ensure that one of the nodes has rabbit running before starting it on other nodes. Looks like a race between the second node joining the cluster and the first node creating all the state tables it needs to track the cluster status

rabbitmq log attached.

Comment 1 John Eckersberg 2014-07-16 18:27:40 UTC
https://github.com/redhat-openstack/astapor/pull/318

Comment 5 John Eckersberg 2014-08-19 20:26:04 UTC

*** This bug has been marked as a duplicate of bug 1122314 ***


Note You need to log in before you can comment on or make changes to this bug.