Bug 112030 - Should install rpm headers for base distro at distro install time
Should install rpm headers for base distro at distro install time
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-12 22:08 EST by Robin Green
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-13 16:36:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robin Green 2003-12-12 22:08:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20030925

Description of problem:
Yum slowly d/ls headers for the base upon first invocation of "yum
update" without any arguments. This is a waste of time, because the
installation process could have installed those headers.

It would be more efficient to just ship a yum-headers.rpm in the
distro so it didn't have to download all these headers from the server
on each machine, and install that rpm by default.

Version-Release number of selected component (if applicable):
2.0.4-2

How reproducible:
Always

Steps to Reproduce:
1. yum update


Actual Results:  It tries to get all the headers in
/var/cache/yum/base/ as well as in /var/cache/yum/updates-released/

Expected Results:  The headers in /var/cache/yum/base/ should have
been preinstalled

Additional info:
Comment 1 Jeff Johnson 2003-12-13 16:36:00 EST
In principle, yum's cache could have been primed by
preparing a package with all the correct headers, yes.

In reality, packages tend to change too rapidly to keep
a yum-headers package up-to-date. Furthermore, it just changes the
problem of cache priming from slow on yum out-of-box to
slow downloading of the yum-headers package before
running yum for no overall win. Sooner or later the user
needs to populate yum's cache with headers.

The current scheme is more flexible but cruder.

Better solutions are in the the works using xml instead of headers.
WONTFIX until then.

Note You need to log in before you can comment on or make changes to this bug.