Bug 1120326 - "network" script does not correctly bring up ovs bridge devices
Summary: "network" script does not correctly bring up ovs bridge devices
Keywords:
Status: CLOSED DUPLICATE of bug 1123081
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: openvswitch
Version: 7.0
Hardware: All
OS: Linux
medium
high
Target Milestone: rc
: ---
Assignee: Flavio Leitner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-16 18:25 UTC by Jeff Dexter
Modified: 2018-12-06 17:21 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-30 16:37:35 UTC


Attachments (Terms of Use)

Description Jeff Dexter 2014-07-16 18:25:39 UTC
Description of problem:
When using a static ip on an ovs-bridge / ovs port, bridge does not get IP address assigned on system startup.  Requires service network restart to get IP address

Version-Release number of selected component (if applicable):
openvswitch-2.0.0-7.el7.x86_64
RHEL7 GA

How reproducible:
always

Steps to Reproduce:
1.Take fresh RHEL7 install, install openvswitch
2.configure network interfaces
$ cat etc/sysconfig/network-scripts/ifcfg-enp3s0 
DEVICE="enp3s0"                                                                 
ONBOOT=yes                                                                      
NM_CONTROLLED=no                                                                BOOTPROTO=none                                                                  
USERCTL=no                                                                      TYPE=OVSPort                                                                    
DEVICETYPE=ovs                                                                  OVS_BRIDGE=br-ex                                                                

$ cat etc/sysconfig/network-scripts/ifcfg-br-ex
DEVICE=br-ex                                                                    
TYPE=OVSBridge                                                                  
ONBOOT=yes                                                                      NM_CONTROLLED=no                                                                
BOOTPROTO=none
IPADDR=10.10.72.45
PREFIX=24
GATEWAY=10.10.72.254
DNS1=10.11.5.3
IPV4_FAILURE_FATAL=yes
IPV6INIT=no
NETMASK=255.255.0.0
USERCTL=no
 
3. reboot server

Actual results:
br-ex does not get an ipadress

Expected results:
br-ex to take ip address

Additional info:
this looks similar to https://bugzilla.redhat.com/show_bug.cgi?id=1051593

Comment 2 Flavio Leitner 2014-07-16 21:01:00 UTC
Are you sure that the 'network' initscript is enabled?
The following command will return the runlevels which the initscript is enabled:
# chkconfig --list network


Can you tell if the bridge is created but there is no IP address or the bridge is not created at all?


Can you tell if after had reproduced the issue, the openvswitch systemd unit is running?
# systemctl status openvswitch


Also, I don't know the customer's requirements here, but the version reported is 2.0.0 version while we have 2.0.1 and 2.1.2 too.

Thanks,
fbl

Comment 3 Flavio Leitner 2014-07-16 21:10:59 UTC
Actually this looks like to be a dup of bz#1072574 (Fedora) and bz#1085492 (RHEL).  Could you upgrade the openvswitch rpm package accordingly?
(fixed version: openvswitch-2.0.1-2.el7)

Comment 4 Jeff Dexter 2014-07-16 21:45:12 UTC
based on using the rhel7 channel and the RHOSP channel these are the versions I see availalbe

[root@jd-rhosp5 monkeh]# yum repolist
Loaded plugins: langpacks, product-id, subscription-manager
repo id                                                                           repo name                                                                                             status
!rhel-7-server-openstack-5.0-rpms/7Server/x86_64                                  Red Hat OpenStack 5.0 for RHEL 7 (RPMs)                                                                 284
!rhel-7-server-rpms/7Server/x86_64                                                Red Hat Enterprise Linux 7 Server (RPMs)                                                              4,502
!rhel-7-server-supplementary-rpms/7Server/x86_64                                  Red Hat Enterprise Linux 7 Server - Supplementary (RPMs)                                                 28
!rhel-ha-for-rhel-7-server-rpms/7Server/x86_64                                    Red Hat Enterprise Linux High Availability (for RHEL 7 Server) (RPMs)                                    34
!rhel-x86_64-server-7-mrg-messaging-2-rpms/x86_64                                 Red Hat Enterprise MRG Messaging 2 for RHEL 7 (RPMs)                                                     24
repolist: 4,872
[root@jd-rhosp5 monkeh]# yum search openvswitch --showduplicates
Loaded plugins: langpacks, product-id, subscription-manager
================================================================================== N/S matched: openvswitch ==================================================================================
openstack-neutron-openvswitch-2014.1-35.el7ost.noarch : Neutron openvswitch plugin
openstack-neutron-openvswitch-2014.1-35.el7ost.noarch : Neutron openvswitch plugin
openvswitch-2.0.0-7.el7.x86_64 : Open vSwitch daemon/database/utilities
openvswitch-2.0.0-7.el7.x86_64 : Open vSwitch daemon/database/utilities
openvswitch-controller-2.0.0-7.el7.x86_64 : Open vSwitch OpenFlow controller
python-openvswitch-2.0.0-7.el7.noarch : Open vSwitch python bindings

  Name and summary matches only, use "search all" for everything


Is there a repository that the openvswitch-2.0.1-2.el7 package is in?

Comment 5 Jeff Dexter 2014-07-17 17:24:39 UTC
@Flavio

openvswitch-2.0.1-2.el7.x86_64.rpm fixes issue but it is not in an accessible repo for RHEL7 users.

Comment 6 Flavio Leitner 2014-07-22 17:47:59 UTC
(In reply to Jeff Dexter from comment #5)
> openvswitch-2.0.1-2.el7.x86_64.rpm fixes issue but it is not in an
> accessible repo for RHEL7 users.

Open vSwitch package is not part of RHEL-7.  It's part of RHOS which needs an update (this is in progress).


Note You need to log in before you can comment on or make changes to this bug.