Bug 112033 - Evolution hangs with 100% CPU usage
Evolution hangs with 100% CPU usage
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
1
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-13 04:14 EST by Jack Spaar
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-20 20:08:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jack Spaar 2003-12-13 04:14:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
Occasionally (2-3 times per week) evolution hangs with 100% CPU usage.
Attempts to exit leave an open message box "Evolution is now exiting..."

It is configured to scan 2 IMAP/SSL accounts (on myrealbox.com) and
one POP account, plus several RSS feeds.

It stays hung for hours until killed.  Upon restarting evolution,
behaviour is normal.

This would be a mere annoyance except for the CPU saturation, which
interferes with other processes.

Sample strace output in Add'l Info section below.

If grabbing a core dump would be helpful let me know.

Version-Release number of selected component (if applicable):
evolution-1.4.5-7

How reproducible:
Sometimes

Steps to Reproduce:
1. unknown, but using multiple secure IMAP accounts in my case
2.
3.
    

Additional info:

Strace output for the busy evolution process looks like the following,
infinitely repeated:
gettimeofday({1071305648, 592617}, NULL) = 0
nanosleep({0, 100000000}, NULL)         = 0
ioctl(3, FIONREAD, [0])                 = 0
gettimeofday({1071305648, 702374}, NULL) = 0
poll([{fd=4, events=POLLIN}, {fd=3, events=POLLIN}, {fd=8,
events=POLLIN|POLLPRI}, {fd=10, events=POLLIN}, {fd=13,
events=POLLIN|POLLPRI}, {fd=14, events=POLLIN|POLLPRI}, {fd=15,
events=POLLIN|POLLPRI}, {fd=12, events=POLLIN|POLLPRI}, {fd=17,
events=POLLIN|POLLPRI}, {fd=16, events=POLLIN|POLLPRI}, {fd=36,
events=POLLIN|POLLPRI}, {fd=37, events=POLLIN|POLLPRI}, {fd=20,
events=POLLIN}, {fd=22, events=POLLIN}, {fd=18, events=POLLIN}], 15,
0) = 0
Comment 1 Bart Martens 2004-01-29 12:20:33 EST
Looks like this one:
http://bugzilla.ximian.com/show_bug.cgi?id=45443
Comment 2 Jack Spaar 2004-01-29 13:13:29 EST
It might be related.  But in contrast to the report you reference, my
problem can begin during a period without any user interaction.  I.e.,
if I leave the computer unattended for several hours, the problem can
begin *during* that time.
Comment 3 Dave Malcolm 2004-09-20 16:25:29 EDT
I'm sorry that this bug report has gone for so long without activity.  

Some questions:
- how large are the IMAP accounts? (the referenced Ximian bug involves
a huge IMAP account)
- are you still experiencing this problem?  What version of Evolution
are you using?
- if you can still reproduce the problem, please can you ensure
evolution-debuginfo is installed, then attempt to attach gdb to the
errant evolution process (determine the id of the evo process using ps
ax, then run gdb, and type "attach <process-id>"), and try to get a
backtrace (type "thread apply all backtrace").
Comment 4 Jack Spaar 2004-09-20 20:08:58 EDT
The IMAP accounts were not big, 10-20 messages each.

I no longer experience the problem with 1.5.9.1 using the same servers.

So feel free to close this bug, thanks.

Note You need to log in before you can comment on or make changes to this bug.