Bug 1120339 - kickstart with LVM on RAID1 fails
Summary: kickstart with LVM on RAID1 fails
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: python-blivet   
(Show other bugs)
Version: 7.0
Hardware: All
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Vratislav Podzimek
QA Contact: Release Test Team
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-16 18:50 UTC by James Boyle
Modified: 2017-05-18 09:19 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-01-05 06:53:35 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda-tb-QsGGx4 (250.83 KB, text/plain)
2014-07-21 16:30 UTC, James Boyle
no flags Details
anaconda.log (3.28 KB, text/x-log)
2014-07-21 16:31 UTC, James Boyle
no flags Details
dmesg (42.01 KB, text/plain)
2014-07-21 16:32 UTC, James Boyle
no flags Details
fdisk (846 bytes, text/x-log)
2014-07-21 16:33 UTC, James Boyle
no flags Details
program.log (12.98 KB, text/x-log)
2014-07-21 16:34 UTC, James Boyle
no flags Details
storage.log (93.99 KB, text/x-log)
2014-07-21 16:34 UTC, James Boyle
no flags Details
storage.state (16.00 KB, application/octet-stream)
2014-07-21 16:35 UTC, James Boyle
no flags Details
syslog (69.54 KB, text/plain)
2014-07-21 16:35 UTC, James Boyle
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1093144 None None None Never

Internal Trackers: 1093144

Description James Boyle 2014-07-16 18:50:20 UTC
Description of problem:
When attempting to use kickstart to create a system with LVM on top of RAID 1, the installer craps out.

Version-Release number of selected component (if applicable):
anaconda 19.31.79-1

How reproducible:
Every time.

Steps to Reproduce:
Attempt to install from a kickstart with the following configuration:
# Format the partitions, clear mbr first
zerombr 
clearpart --all --initlabel

part raid.00 --size 768 --asprimary --ondrive=vda
part raid.10 --size 768 --asprimary --ondrive=vdb
part raid.01 --size 4096 --asprimary --ondrive=vda
part raid.11 --size 4096 --asprimary --ondrive=vdb
part raid.02 --size 1024 --asprimary --grow --ondrive=vda
part raid.12 --size 1024 --asprimary --grow --ondrive=vdb

raid /boot --fstype ext3 --device raid1-boot --level=RAID1 raid.00 raid.10
raid swap --fstype swap --device raid1-swap --level=RAID1 raid.01 raid.11
raid pv.00 --device raid1-pv --level=RAID1 raid.02 raid.12

volgroup vg0 pv.00

# Create more logical partitions
# CCE-14161-4, CCE-14777-2, CCE-14011-1, CCE-14171-3, CCE-14559-9  (Rows 2 - 6)

logvol / --fstype ext4 --name=root --vgname=vg0 --grow --size=1024
logvol /tmp  --fstype ext4 --name=temp --vgname=vg0 --size=32768 --fsoptions="nodev,noexec,nosuid"
logvol /home --fstype ext4 --name=home --vgname=vg0 --size=65536 --fsoptions="nodev"
logvol /var  --fstype ext4 --name=var  --vgname=vg0 --size=32768 --fsoptions="nodev"
logvol /var/log --fstype ext4 --name=varlog --vgname=vg0 --size=8192 --fsoptions="nodev,noexec,nosuid"
logvol /var/log/audit --fstype ext4 --name=audit --vgname=vg0 --size=4096 --fsoptions="nodev,noexec,nosuid"

Actual results:
Anaconda crashes; installation is halted.

Expected results:
The system should install with the configuration as detailed in the kickstart file.

Additional info:
Works in 6.5

Comment 2 Brian Lane 2014-07-18 01:09:16 UTC
Please attach the logs from /tmp/*log as individual text/plain attachments to this bug.

Comment 3 James Boyle 2014-07-21 16:30:54 UTC
Created attachment 919681 [details]
anaconda-tb-QsGGx4

Comment 4 James Boyle 2014-07-21 16:31:24 UTC
Created attachment 919682 [details]
anaconda.log

Comment 5 James Boyle 2014-07-21 16:32:46 UTC
Created attachment 919684 [details]
dmesg

Comment 6 James Boyle 2014-07-21 16:33:26 UTC
Created attachment 919685 [details]
fdisk

Comment 7 James Boyle 2014-07-21 16:34:06 UTC
Created attachment 919687 [details]
program.log

Comment 8 James Boyle 2014-07-21 16:34:37 UTC
Created attachment 919688 [details]
storage.log

Comment 9 James Boyle 2014-07-21 16:35:05 UTC
Created attachment 919689 [details]
storage.state

Comment 10 James Boyle 2014-07-21 16:35:24 UTC
Created attachment 919690 [details]
syslog

Comment 11 James Boyle 2014-07-21 16:37:14 UTC
The information I just added happened from a slightly different kickstart file -- it's the same as the one I already posted, but every logical volume except for "/" is commented out.

Comment 13 Vratislav Podzimek 2014-09-03 09:48:39 UTC
I think this could be a duplicate of bug 1093144 with a fix already available. Let's see if fixing bug 1093144 fixes this too.

Comment 15 Martin Banas 2014-12-15 08:13:35 UTC
I just verified that this bug is fixed on RHEL-7.1 Beta.

James, could you please check if it also works for you?

Thanks!

Comment 16 James Boyle 2015-01-02 21:57:21 UTC
Confirmed - the kickstart file now works with rhel-server-7.1-beta-1-x86_64

Happy New Year!
--James

Comment 17 Martin Banas 2015-01-05 06:53:35 UTC
Thanks!

Closing the bug.


Note You need to log in before you can comment on or make changes to this bug.