Bug 1120374 - support WPA Enterprise based wireless access points
Summary: support WPA Enterprise based wireless access points
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda
Version: 7.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Radek Vykydal
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-16 19:28 UTC by Ray Strode [halfline]
Modified: 2015-03-09 15:42 UTC (History)
3 users (show)

Fixed In Version: anaconda-19.31.90-1
Doc Type: Bug Fix
Doc Text:
Cause: Anaconda did not support WPA Enterprise wireless connections. Consequence: Could not install over a WPA Enterprise wireless connection. Fix: Write code. Result: Anaconda can now use a WPA Enterprise wireless connection for the installation.
Clone Of:
Environment:
Last Closed: 2015-03-05 14:02:05 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0312 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2015-03-05 17:35:22 UTC
Red Hat Bugzilla 892896 None None None Never

Internal Links: 892896

Description Ray Strode [halfline] 2014-07-16 19:28:54 UTC
Matthias was trying to do a RHEL 7 install over wifi today and hit a snag.  If he chose "Red Hat" for the access point, nothing would happen.

We were expecting to see a dialog asking for PEAP, GTC, No CA Cert, etc, but instead it just showed a grayed out Configure button.

If we went to a VT to look at the anaconda messages, there was an error about "No agent available".

We were able to get it to work by running nm-connection-editor from tty2 and setting up the connection manually.

Radek says:

  We are not using nm-applet but our own SecretAgent
  which does not support wpa2 enterprise. Please file a RFE
  for RHEL.
  (https://bugzilla.redhat.com/show_bug.cgi?id=892896)

  We'd love to share the code (use nm-applet) in this case,
  we tried to integrate it in installer environment but finally
  we had to go with our own SecretAgent.
  IIRC the main reason was that the installer not being normal desktop
  environment with common wm function (but taking over
  all the desktop as one application) we wouldn't be able to
  control stacking of dialog widgets of another processes
  reasonably (in a similar way as with nm-c-e at the moment
  - the issue of dialog getting hidden behind anaconda UI 
  when clicking outside the dialog).
  There might have been other reasons as well.

  This may get better with present changes by David Shea
  (run anaconda in one window) in master. For nm-c-e it will
  be improved by adding modality option:
  https://bugzilla.redhat.com/show_bug.cgi?id=1097883

  So to move forward here, there are some options:

  - re-try harder to use nm-applet in installer
  - add support for wpa2 enterprise to our SecretAgent
  - allow to add the connection manually using nm-c-e from GUI,
     ie integrate workaround Ray used into GUI via
     existing [+] button which serves for adding virtual devices/connections
     (vlan, bond, team) currently.

Comment 1 David Cantrell 2014-07-18 19:22:31 UTC
*** Bug 1061796 has been marked as a duplicate of this bug. ***

Comment 2 Radek Vykydal 2014-09-11 11:49:26 UTC
For rhel 7.1 we will use nm-c-e to set up wireless security [1] and our secret agent to ask for password. So the flow is:

1) Select AP in combobox (anaconda will create a connection for the AP)
2) Hit [Configure] to configure wireless security for the connection in nm-c-e. 
3) Secret agent asks for password if needed.

I've tested patches with our "Red Hat" AP in Brno. If anybody wants to try them out too, I've prepared anaconda updates image for RHEL 7.0, to apply it, use

updates=https://rvykydal.fedorapeople.org/updates.r70wpaenterprise.img

installer boot option.

[1] In the future we might be able to use NMGtk.WifiDialog but now we are blocked by https://bugzilla.gnome.org/show_bug.cgi?id=702762.

Comment 3 Radek Vykydal 2014-09-11 12:05:15 UTC
(In reply to Radek Vykydal from comment #2)
 
> I've tested patches with our "Red Hat" AP in Brno. If anybody wants to try
> them out too, I've prepared anaconda updates image for RHEL 7.0, to apply
> it, use
> 
> updates=https://rvykydal.fedorapeople.org/updates.r70wpaenterprise.img
> 
> installer boot option.

I've also added extra debugging info to the image.
If it fails for your AP, please attach /tmp/anaconda-tb-* in case of traceback, or /tmp/anaconda.log and /tmp/syslog if there is no traceback.

Comment 7 errata-xmlrpc 2015-03-05 14:02:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0312.html


Note You need to log in before you can comment on or make changes to this bug.