Bug 1120386 - sym link in boost_python3 missing
Summary: sym link in boost_python3 missing
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: boost
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Machata
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-16 19:52 UTC by Ganapathi Kamath
Modified: 2015-05-05 01:38 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-16 21:43:36 UTC


Attachments (Terms of Use)

Description Ganapathi Kamath 2014-07-16 19:52:49 UTC
Description of problem:
when trying to compile a test program the code can't find the library by the common name of the library
$ g++ -lpython3.4m  -lboost_python3 -shared -lstdc++ greetmod.o -o greetmod.so 
/usr/bin/ld: cannot find -lboost_python3
collect2: error: ld returned 1 exit status

this is because a symlink is missing
ln -s libboost_python3.so  libboost_python3.so.1.55.0
the corry
espinding symlink for libboost_python3.so is present

# cd /usr/lib64
# ls -l libboost_pytho*
-rwxr-xr-x. 1 root root 318808 Jun  7 00:49 libboost_python3.so.1.55.0
lrwxrwxrwx. 1 root root     25 Jun  7 00:44 libboost_python.so -> libboost_python.so.1.55.0
-rwxr-xr-x. 1 root root 318704 Jun  7 00:49 libboost_python.so.1.55.0

Version-Release number of selected component (if applicable):
# rpm -qa | egrep -i boost-python*
boost-python-1.55.0-2.fc21.x86_64
boost-python3-1.55.0-2.fc21.x86_64

How reproducible:
everytime ?
# rpm -qil boost-python3-1.55.0-2.fc21.x86_64 | egrep -i lib64
/usr/lib64/libboost_python3.so.1.55.0


Steps to Reproduce:
1. see if sym link exists:  ls -l /usr/lib64/libboost_pytho*

Actual results:
only one symlink exists

Expected results:
two symlinks one for libboost_python.so and libboostpython3.so should exits


Additional info:
workaround: just create the symlink 
# ln -s libboost_python3.so.1.55.0 libboost_python3.so

Example boost-python
http://www.boost.org/doc/libs/1_55_0/libs/python/doc/tutorial/doc/html/index.html

Comment 1 Petr Machata 2014-07-16 21:43:36 UTC
This is shipped in boost-python3-devel.

Comment 2 Ganapathi Kamath 2014-07-17 02:24:07 UTC
acknowledged.


Note You need to log in before you can comment on or make changes to this bug.