Bug 1120393 - No support for Intersil Prism cards (PCI or PCMCIA)
Summary: No support for Intersil Prism cards (PCI or PCMCIA)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-16 19:58 UTC by Pavel Roskin
Modified: 2014-07-20 03:25 UTC (History)
6 users (show)

Fixed In Version: kernel-3.15.6-200.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-20 03:25:58 UTC


Attachments (Terms of Use)

Description Pavel Roskin 2014-07-16 19:58:25 UTC
Description of problem:
Neither kernel nor kernel-modules-extra include support for Intersil Prism chipset. The kernel is compiled without CONFIG_HERMES_PRISM, which disables Prism chipset support in orinoco_cs, orinoco_plx and orinoco_nortel modules and disables orinoco_pci module completely.  CONFIG_HOSTAP is also disabled.

Version-Release number of selected component (if applicable):
3.15.4-200.fc20

How reproducible:
Always

Steps to Reproduce:
1. Install a Prism2 or Prism2.5 card
2. Boot Fedora 20

Actual results:
The card is not detected by the kernel, no module is loaded

Expected results:
The card is detected

Additional info:
I understand that Prism chipset is old, but it was a market leader ten years ago.  Not supporting it leave old computers without wireless connectivity.  That's the computers that are migrating to Linux because Windows XP is not supported anymore.  We should care.

Enabling hostap would be a much better choice, as the hostap driver supports WPA and the orinoco (hermes) driver doesn't.  But is enabling hostap is ruled out please at least enable CONFIG_HERMES_PRISM.  The whole point in having that option is to avoid a conflict with hostap that is not enabled anyway.

Comment 1 Josh Boyer 2014-07-16 21:45:34 UTC
Enabled in the next build.  Note that this driver is ancient and we really can't support it.  If bugs are reported against it we'll direct people upstream and close the bug as UPSTREAM.

Comment 2 Fedora Update System 2014-07-18 13:26:26 UTC
kernel-3.15.6-200.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/kernel-3.15.6-200.fc20

Comment 3 Fedora Update System 2014-07-19 06:03:49 UTC
Package kernel-3.15.6-200.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.15.6-200.fc20'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-8519/kernel-3.15.6-200.fc20
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2014-07-20 03:25:58 UTC
kernel-3.15.6-200.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.