Bug 1120396 - Post script output not written to log
Summary: Post script output not written to log
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-16 20:05 UTC by Ross Smith
Modified: 2014-07-21 19:05 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-21 19:05:44 UTC


Attachments (Terms of Use)
kickstart file with %post script (80 bytes, text/plain)
2014-07-16 20:05 UTC, Ross Smith
no flags Details

Description Ross Smith 2014-07-16 20:05:21 UTC
Created attachment 918510 [details]
kickstart file with %post script

Description of problem:
During a kickstart %post script (without --nochroot option) a log file is created in the non-chrooted filesystem that is empty even if the script produces output.  

Version-Release number of selected component (if applicable): rhel7GA


How reproducible: always


Steps to Reproduce:
1. start kickstart installation with a %post script that produces output
2. cat logfile in /tmp corresponding to post script in /mnt/sysimage/tmp


Actual results:
Empty log file

Expected results:
Log file containing output of %post script

Additional info:

Comment 2 Brian Lane 2014-07-18 01:10:31 UTC
Check /var/log/anaconda/ on the target system. Is it there?

Comment 3 Ross Smith 2014-07-21 13:03:17 UTC
Once installation is complete the post script logs show up in /var/log/anaconda/ on the target system.  While the scripts are running there is no corresponding log file on the target system.  The ks-script-xxx log in /tmp also remains empty while the scripts are running.

Comment 4 Brian Lane 2014-07-21 18:55:58 UTC
That is as expected, because of buffering the output may not be written to the files immediately.

Comment 5 RHEL Product and Program Management 2014-07-21 19:05:44 UTC
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.


Note You need to log in before you can comment on or make changes to this bug.