Bug 1120403 - [abrt] firewall-config: firewall-config:1995:onChangeZone:TypeError: 'NoneType' object has no attribute '__getitem__'
Summary: [abrt] firewall-config: firewall-config:1995:onChangeZone:TypeError: 'NoneTyp...
Keywords:
Status: CLOSED DUPLICATE of bug 995760
Alias: None
Product: Fedora
Classification: Fedora
Component: firewalld
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:c267f39a7a97ec6f2810da8dcdc...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-16 20:30 UTC by andrew
Modified: 2014-07-22 12:43 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-22 12:43:27 UTC


Attachments (Terms of Use)
File: backtrace (616 bytes, text/plain)
2014-07-16 20:30 UTC, andrew
no flags Details
File: environ (1.33 KB, text/plain)
2014-07-16 20:30 UTC, andrew
no flags Details

Description andrew 2014-07-16 20:30:38 UTC
Version-Release number of selected component:
firewall-config-0.3.10-1.fc20

Additional info:
reporter:       libreport-2.2.2
cmdline:        /usr/bin/python -Es /usr/bin/firewall-config
executable:     /usr/bin/firewall-config
kernel:         3.15.4-200.fc20.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
firewall-config:1995:onChangeZone:TypeError: 'NoneType' object has no attribute '__getitem__'

Traceback (most recent call last):
  File "/usr/bin/firewall-config", line 1995, in onChangeZone
    _services = services[:]
TypeError: 'NoneType' object has no attribute '__getitem__'

Local variables in innermost frame:
masquerade: False
default: False
interfaces: ['em1']
args: (<TreeSelection object at 0x2eaec30 (GtkTreeSelection at 0x2a4bfa0)>,)
self: <__main__.FirewallConfig object at 0x28e8350>
sources: []
builtin: False
icmpblocks: []
rules: []
services: None
active_zone: 'public'
ports: []
forward_ports: []

Comment 1 andrew 2014-07-16 20:30:40 UTC
Created attachment 918517 [details]
File: backtrace

Comment 2 andrew 2014-07-16 20:30:40 UTC
Created attachment 918518 [details]
File: environ

Comment 3 Jiri Popelka 2014-07-22 12:43:27 UTC

*** This bug has been marked as a duplicate of bug 995760 ***


Note You need to log in before you can comment on or make changes to this bug.