Bug 1120405 - as many as 10 journalctl running simultaneously with no apparent reason
Summary: as many as 10 journalctl running simultaneously with no apparent reason
Keywords:
Status: CLOSED DUPLICATE of bug 1043670
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-16 20:40 UTC by lejeczek
Modified: 2014-10-15 10:36 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-16 20:52:34 UTC


Attachments (Terms of Use)

Description lejeczek 2014-07-16 20:40:14 UTC
Description of problem:

I find these heat up the system a lot

18928 root      20   0  993468  19648  19288 R  45.6  0.2  16:22.11 journalctl _UID=1000 -b      18927 
19260 root      20   0  992092  16508  16140 R  45.6  0.2   9:07.41 journalctl _UID=1000 -b      19259 
18228 root      20   0  988344  44256  43892 R  45.3  0.6  64:23.13 journalctl _UID=1000 -b      18227 
18932 root      20   0 1000628  19604  19240 R  43.3  0.2  16:15.63 journalctl _UID=1000 -b      18931 
19264 root      20   0  996372  16440  16080 R  41.6  0.2   9:08.67 journalctl _UID=1000 -b      19263 
18520 root      20   0  991832  37732  37364 R  41.0  0.5  47:11.90 journalctl _UID=1000 -b      18519 
18680 root      20   0  992896  23460  23100 R  40.6  0.3  26:53.42 journalctl _UID=1000 -b      18679 
18277 root      20   0  988344  45312  44952 R  39.6  0.6  61:53.62 journalctl _UID=1000 -b      18276 
18350 root      20   0  988344  44536  44176 R  37.3  0.6  59:48.80 journalctl _UID=1000 -b      18349


I cannot know what causes all these journactl to run, I close all the desktop apps maybe only gnome-terminal left open and running.
I cannot tell if there is any pattern in the way these multiple process come to existence.

How can I gather any useful debugging information for further troubleshooting?

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Zbigniew Jędrzejewski-Szmek 2014-07-16 20:52:34 UTC
I'll take a wild guess, and mark this as duplicate.

(You can try 'systemctl status <PID>' to find the service).

*** This bug has been marked as a duplicate of bug 1043670 ***

Comment 2 lejeczek 2014-07-18 08:19:15 UTC
my situation I'm inclined to attribute it to (directly or not) Firefox.
it seems that after so many firefox windows and tabs open these processes would pop up. Seems like when there is flash content in the browser this happens but at the same time I must say closing/killing firefox does not relief journalctl processes, at least not in a short time right after.
And not really abrt doing anything, moreover I clean the list of event recorded by abrt.

Comment 3 Zbigniew Jędrzejewski-Szmek 2014-07-18 12:26:12 UTC
What does 'systemctl status <PID>' say about those processes?

Comment 4 lejeczek 2014-07-18 14:42:52 UTC
looking at it further, it might be related, I see multiple:
 grep -F -e plugin-container
and abrt logs but! is unable to report it further up Firefox:

Firefox C/C++ plugin-container killed by SIGSEGV

when I try to report it:

--- Running report_uReport ---
Unable to open './core_backtrace': Permission denied.
reporter-ureport failed with exit code 1
('report_uReport' exited with 1)

I try to upload for analysis:

--- Running report_uReport ---
Unable to open './core_backtrace': Permission denied.
reporter-ureport failed with exit code 1
('report_uReport' exited with 1)

--- Running report_EmergencyAnalysis ---
Compressing data
Can't create temporary file in /var/tmp

So, in my case it's Firefox and abrt which first cannot handle this error case and then there is that other bug.

Comment 5 lejeczek 2014-07-19 06:23:12 UTC
is it possible to exclude an app from programs that abrt is watching for?

Comment 6 Jakub Filak 2014-10-15 10:36:35 UTC
(In reply to lejeczek from comment #5)
> is it possible to exclude an app from programs that abrt is watching for?

You cat put either package or path on blacklist in /etc/abrt/abrt-action-save-package-data.conf


Note You need to log in before you can comment on or make changes to this bug.