Bug 112041 - ogg123 exits with the message - libao - OSS cannot set rate to 44100
ogg123 exits with the message - libao - OSS cannot set rate to 44100
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libao (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Colin Walters
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-13 10:24 EST by Alaeddin A. Aydiner
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-22 00:47:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alaeddin A. Aydiner 2003-12-13 10:24:54 EST
Description of problem:

I can play ogg files with rhythmbox, xmms etc., but ogg123 refuses to
play it. This seems to be a problem related to the i810_audio module
as well as to libao. A typical output is as follows:

libao - OSS cannot set rate to 44100
Error: Cannot open device oss.

The hardware is a Sony Vaio V505BX laptop which contains an Intel
82801CA/CAM AC'97 Audio Controller. In my /etc/modules.conf, the
relevant lines are:

alias sound-slot-0 i810_audio
options i810_audio clocking=48000

The result did not improve with the above clocking option although
I thought it would.

Version-Release number of selected component (if applicable):
vorbis-tools-1.0-7

How reproducible: Always.


Steps to Reproduce:
1. ogg123 my.ogg
  
Actual results:

libao - OSS cannot set rate to 44100
Error: Cannot open device oss.

Expected results:

No errors.

Additional info:
Comment 1 J.B. Nicholson-Owens 2004-01-17 01:19:40 EST
ogg123 with my i810 audio gives me interesting results.  My FC1 is
fully up to date as of the time/date stamp of this post.  Consider two
sources:

  1. http://www.archive.org/download/dn2004-0116/dn2004-0116-1.ogg
  2. http://aud-one.kpfa.org:8090/kpfa.ogg

and two sounds daemons: OSS and ESounD.

ESD plays both sources perfectly.  All I have to do is specify
--device=esd and ogg123 is fine.

OSS (the default sound device) won't play the KPFA live stream at all
("libao - OSS cannot set rate to 14000" then "Error: Cannot open
device oss.").  The DN show is played way too fast, it sounds like
everyone on the show is a chipmunk.

Rhythmbox 0.5.4 plays DN too quickly and  the live KPFA stream won't
play at all (both the same as ogg123 with OSS).  I can't change
Rhythmbox's sound daemon.
Comment 2 Colin Walters 2004-09-21 22:52:51 EDT
Alaeddin: You added the clocking option manually?  Removing it doesn't
help?

Also we've switched to ALSA as the default for FC2, so things have
certainly changed since this bug was opened.  Can you guys reproduce
this with FC2?
Comment 3 Alaeddin A. Aydiner 2004-09-22 00:20:59 EDT
Hi Colin,

I am running Fedora Core 2 for some time now, and all is fixed for me.
Feel free to close the ticket.

Thank you.

Alaeddin.
Comment 4 Colin Walters 2004-09-22 00:47:41 EDT
Thanks.

Note You need to log in before you can comment on or make changes to this bug.