Bug 112043 - unregister_netdevice error preventing shutdown
unregister_netdevice error preventing shutdown
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-13 11:13 EST by Mike Zanker
Modified: 2013-07-02 22:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-18 02:27:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Zanker 2003-12-13 11:13:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET 
CLR 1.0.3705; .NET CLR 1.1.4322)

Description of problem:
When unplugging a PCMCIA network card (have tried a few different 
ones) the following error message appears on the console:

kernel: unregister_netdevice: waiting for eth0 to become free. Usage 
count = 2

and is repeated every few seconds. This seems to prevent the machine 
being shut down so that removing the power is necessary. Also, the 
PCMCIA card will not work if re-inserted until machine has been 
rebooted.

Have also tried a prism2 wireless card which uses the device wlan0. 
Same thing happens with eth0 replaced by wlan0 in the kernel message.

Version-Release number of selected component (if applicable):
kernel-2.4.21-4.0.1.EL

How reproducible:
Always

Steps to Reproduce:
1. Insert PCMCIA network card. Card works fine (IP address allocated 
via DHCP, IP packets flow).
2. Remove card, or shutdown/reboot machine. 
3.    

Actual Results:  At the point that the card is removed or card 
services shut down the above kernel messages begin to be logged. 
Shutdown/reboot never completes.

Expected Results:  Expect card to be removed without above message 
being logged and machine to shut down cleanly.

Additional info:
Comment 1 Mike Zanker 2003-12-13 11:56:33 EST
A workaround seems to be to "ifconfig eth0 (or wlan0) down" before 
removing the card or shutting down the system. The module is 
successfully unloaded after doing this.
Comment 2 Jeff Garzik 2004-01-12 13:50:22 EST
Are you using IPv6 also?
Comment 3 Mike Zanker 2004-01-14 08:52:30 EST
Hi Jeff - yes, I'm using IPv6.
Comment 4 Jeff Garzik 2004-06-14 13:26:58 EDT
What driver?  What hardware?
Comment 5 Mike Zanker 2004-06-14 14:38:52 EDT
This bug was fixed some time ago in one of the subsequent kernel 
releases.
Comment 8 Ernie Petrides 2005-03-02 14:04:58 EST
We believe this was fixed in RHEL3 U2, which was advisory RHSA-2004:188.

Note You need to log in before you can comment on or make changes to this bug.