Bug 1120437 - [EARLY ACCESS] peer probe name resolution issue
Summary: [EARLY ACCESS] peer probe name resolution issue
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: core
Version: rhgs-3.0
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Kaushal
QA Contact: storage-qa-internal@redhat.com
URL:
Whiteboard:
: 1187179 1187187 (view as bug list)
Depends On:
Blocks: 1087818
TreeView+ depends on / blocked
 
Reported: 2014-07-16 23:18 UTC by Jacob Shucart
Modified: 2016-09-20 05:18 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
Executing peer-status command on probed host displays the IP address of the node on which the peer probe was performed. Example: When probing a peer, node B with hostname from node A, executing peer-status command on node B, displays IP address of node A instead of its hostname. Workaround: Probe node A from node B with hostname of node A. Execute the following command on node B. #gluster peer probe <HostnameA>
Clone Of:
Environment:
Last Closed: 2015-12-30 09:53:45 UTC


Attachments (Terms of Use)

Description Jacob Shucart 2014-07-16 23:18:07 UTC
Description of problem in RHS 3.0 Early Access release:

peer status on probed host shows IP of the host you ran the peer probe from.  This actually causes issues if you were to, for example, change an IP address associated with a host.

How reproducible:

100%

Steps to Reproduce:
1. On host1, run gluster peer probe to host2
2. On host2, run gluster peer status
3. Observe the fact that it shows the IP address of host1 instead of the hostname

Actual results:

it shows the IP address of host1 instead of the hostname

Expected results:

It should show the hostname of host1

Additional info:

On host2, if you were to then peer probe host1, it would say it was successful and peer status on host2 would show the hostname as it should.

Comment 3 Shalaka 2014-07-25 09:43:23 UTC
Please add doc text for this known issue.

Comment 4 Shalaka 2014-09-20 10:22:04 UTC
Please review and sign-off edited doc text.

Comment 5 Atin Mukherjee 2014-10-20 11:04:44 UTC
doc text reviewed and looks okay to me.

Comment 6 SATHEESARAN 2015-01-29 17:47:55 UTC
*** Bug 1187187 has been marked as a duplicate of this bug. ***

Comment 7 SATHEESARAN 2015-01-30 06:37:28 UTC
*** Bug 1187179 has been marked as a duplicate of this bug. ***

Comment 10 Atin Mukherjee 2015-12-30 09:53:45 UTC
This issue has been already fixed by https://code.engineering.redhat.com/gerrit/#/c/52786/


Note You need to log in before you can comment on or make changes to this bug.