Bug 1120441 - PastDataAggregator: error aggregating data; Preconditions.checkArgument failed
Summary: PastDataAggregator: error aggregating data; Preconditions.checkArgument failed
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: RHQ Project
Classification: Other
Component: Core Server, Storage Node
Version: 4.12
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: ---
: RHQ 4.13
Assignee: John Sanda
QA Contact: Mike Foley
URL:
Whiteboard:
Depends On: 1120775
Blocks: 1133605
TreeView+ depends on / blocked
 
Reported: 2014-07-17 00:07 UTC by Elias Ross
Modified: 2014-09-11 16:01 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-11 16:01:17 UTC


Attachments (Terms of Use)

Description Elias Ross 2014-07-17 00:07:53 UTC
Description of problem:

00:05:04,064 WARN  [org.rhq.server.metrics.aggregation.PastDataAggregator] (StorageClientThreadPool-2) There was an error aggregating data: java.lang.IllegalArgumentException
        at com.google.common.base.Preconditions.checkArgument(Preconditions.java:76) [guava-14.0.1.jar:]
        at org.rhq.server.metrics.aggregation.CombinedMetricsIterator.<init>(CombinedMetricsIterator.java:28) [rhq-server-metrics-4.12.0.jar:4.12.0]
        at org.rhq.server.metrics.aggregation.PastDataAggregator$3$1.iterator(PastDataAggregator.java:370) [rhq-server-metrics-4.12.0.jar:4.12.0]
        at org.rhq.server.metrics.aggregation.BaseAggregator$2.apply(BaseAggregator.java:283) [rhq-server-metrics-4.12.0.jar:4.12.0]
        at org.rhq.server.metrics.aggregation.BaseAggregator$2.apply(BaseAggregator.java:279) [rhq-server-metrics-4.12.0.jar:4.12.0]
        at com.google.common.util.concurrent.Futures$1.apply(Futures.java:720) [guava-14.0.1.jar:]
        at com.google.common.util.concurrent.Futures$ChainingListenableFuture.run(Futures.java:859) [guava-14.0.1.jar:]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_40]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_40]
        at java.lang.Thread.run(Thread.java:724) [rt.jar:1.7.0_40]

This is thrown after doing an upgrade from RHQ 4.9 to 4.12


Version-Release number of selected component (if applicable): 4.12


How reproducible: Unclear

Comment 4 John Sanda 2014-09-11 16:01:17 UTC
I am closing this since the code involved has been removed as part of the work for bug 1114202.


Note You need to log in before you can comment on or make changes to this bug.