Bug 1120445 - AlertAvailabilityDurationJob must implement the Job interface
Summary: AlertAvailabilityDurationJob must implement the Job interface
Keywords:
Status: CLOSED DUPLICATE of bug 1119331
Alias: None
Product: RHQ Project
Classification: Other
Component: Alerts
Version: 4.12
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: ---
: ---
Assignee: RHQ Project Maintainer
QA Contact: Mike Foley
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-17 00:18 UTC by Elias Ross
Modified: 2014-07-18 13:21 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-17 13:43:04 UTC


Attachments (Terms of Use)

Description Elias Ross 2014-07-17 00:18:53 UTC
Description of problem:

After upgrade from RHQ 4.9 to 4.12 I see this:

00:13:49,192 ERROR [org.quartz.impl.jdbcjobstore.JobStoreCMT] (QuartzScheduler_RHQScheduler-vp25q03ad-hadoop098.iad.apple.com1405548327875_MisfireHandler) MisfireHandler: Error handling misfires: Couldn't store trigger 'AVAIL_DURATION_DOWN-37925015639' for 'org.rhq.enterprise.server.scheduler.jobs.AlertAvailabilityDurationJob' job:Job class must implement the Job interface.: org.quartz.JobPersistenceException: Couldn't store trigger 'AVAIL_DURATION_DOWN-37925015639' for 'org.rhq.enterprise.server.scheduler.jobs.AlertAvailabilityDurationJob' job:Job class must implement the Job interface. [See nested exception: java.lang.IllegalArgumentException: Job class must implement the Job interface.]
        at org.quartz.impl.jdbcjobstore.JobStoreSupport.storeTrigger(JobStoreSupport.java:1246) [quartz-1.6.5.jar:1.6.5]
        at org.quartz.impl.jdbcjobstore.JobStoreSupport.doUpdateOfMisfiredTrigger(JobStoreSupport.java:1014) [quartz-1.6.5.jar:1.6.5]
        at org.quartz.impl.jdbcjobstore.JobStoreSupport.recoverMisfiredJobs(JobStoreSupport.java:956) [quartz-1.6.5.jar:1.6.5]
        at org.quartz.impl.jdbcjobstore.JobStoreSupport.doRecoverMisfires(JobStoreSupport.java:3126) [quartz-1.6.5.jar:1.6.5]
        at org.quartz.impl.jdbcjobstore.JobStoreSupport$MisfireHandler.manage(JobStoreSupport.java:3887) [quartz-1.6.5.jar:1.6.5]
        at org.quartz.impl.jdbcjobstore.JobStoreSupport$MisfireHandler.run(JobStoreSupport.java:3907) [quartz-1.6.5.jar:1.6.5]
Caused by: java.lang.IllegalArgumentException: Job class must implement the Job interface.
        at org.quartz.JobDetail.setJobClass(JobDetail.java:280) [quartz-1.6.5.jar:1.6.5]
        at org.quartz.impl.jdbcjobstore.StdJDBCDelegate.selectJobDetail(StdJDBCDelegate.java:897) [quartz-1.6.5.jar:1.6.5]
        at org.quartz.impl.jdbcjobstore.JobStoreSupport.storeTrigger(JobStoreSupport.java:1202) [quartz-1.6.5.jar:1.6.5]
        ... 5 more


I'm guessing this is because the old job was still in the database. Unclear if and when this may disappear, it has been several hours.

It may make sense to simply implement the Quartz interface and simply do nothing.


Version-Release number of selected component (if applicable): 4.12


How reproducible: After upgrade.


Steps to Reproduce:
1. Update from RHQ 4.9 to 4.12 with these jobs
2. ???

Comment 1 Jay Shaughnessy 2014-07-17 13:43:04 UTC
Elias, good feedback, this just came up in Bug 1119331.  See that one for a fix you can apply.  Marking this as duplicate.

*** This bug has been marked as a duplicate of bug 1119331 ***


Note You need to log in before you can comment on or make changes to this bug.