Bug 1120511 - [gvfs] ``No application is registered as handling this file'' despite PDF document viewer being installed
Summary: [gvfs] ``No application is registered as handling this file'' despite PDF doc...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: glib2
Version: 21
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-17 06:01 UTC by Joachim Frieben
Modified: 2014-09-05 03:12 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-05 03:12:16 UTC


Attachments (Terms of Use)
Screenshot of nautilus open file action (13.49 KB, image/png)
2014-08-21 05:17 UTC, Joachim Frieben
no flags Details

Description Joachim Frieben 2014-07-17 06:01:00 UTC
Description of problem:
Despite ``evince'' being installed on my system, xdg-open returns the following error message when applied to a PDF file from the command line:
  $ xdg-open test.pdf 
  gvfs-open: test.pdf: error opening location: No application
  is registered as handling this file
Accordingly, the PDF file is neither opened nor displayed.

Version-Release number of selected component (if applicable):
gvfs-1.21.3-1.fc21

How reproducible:
Always

Steps to Reproduce:
1. xdg-open test.pdf

Actual results:
gvfs-open: test.pdf: error opening location: No application is registered
as handling this file

Expected results:
PDF file is opened and displayed.

Additional info:
evince is installed and 'evince test.pdf' works as expected.

Comment 1 Joachim Frieben 2014-07-19 14:48:48 UTC
No improvement for gvfs-1.21.4-1.fc21.

Comment 2 Joachim Frieben 2014-08-18 08:21:32 UTC
No improvement for gvfs-1.21.90-1.fc21.

Comment 3 Ondrej Holy 2014-08-20 16:46:29 UTC
The problem is likely in glib, because gvfs is just wrapper for glib/gio in this case. This could be connected with new mimeapps spec implementation, see:
https://bugzilla.gnome.org/show_bug.cgi?id=728040

Comment 4 Ondrej Holy 2014-08-20 16:51:48 UTC
Does it work correctly if you try to open the file from nautilus?

Comment 5 Joachim Frieben 2014-08-21 05:17:38 UTC
Created attachment 929018 [details]
Screenshot of nautilus open file action

No, it does not (see attached screenshot).

Comment 6 Matthias Clasen 2014-09-05 03:12:16 UTC
glib just got a fix for mimetype handling that might very well fix this.


Note You need to log in before you can comment on or make changes to this bug.