Bug 1120562 - Prompt "Command [firewall-cmd, --reload] returned non-zero exit status 252" when configuring ssh
Summary: Prompt "Command [firewall-cmd, --reload] returned non-zero exit status 252" w...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.5.0
Assignee: Douglas Schilling Landgraf
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On:
Blocks: rhevh-7.0
TreeView+ depends on / blocked
 
Reported: 2014-07-17 07:21 UTC by haiyang,dong
Modified: 2016-02-10 20:11 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-11 20:59:57 UTC
oVirt Team: Node


Attachments (Terms of Use)
attached Screenshot for configuring ssh.png (8.62 KB, image/png)
2014-07-17 07:21 UTC, haiyang,dong
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC
oVirt gerrit 30588 None None None Never
oVirt gerrit 30590 master MERGED rhevh7-install: replaces iptables to firewalld Never

Description haiyang,dong 2014-07-17 07:21:49 UTC
Created attachment 918622 [details]
attached Screenshot for configuring ssh.png

Description of problem:
Prompt "Command [firewall-cmd, --reload] returned non-zero exit status 252" when configuring ssh
(Seen configuring ssh.png)


Version-Release number of selected component (if applicable):
ovirt-node-3.1.0-0.5.20140711git7197118.el7.noarch.rpm
rhev-hypervisor7-7.0-20140714.0.iso


How reproducible:
100%

Steps to Reproduce:


Actual results:

Expected results:

Additional info:

Comment 1 Douglas Schilling Landgraf 2014-07-23 01:41:37 UTC
The two patches attached should resolve the report.

Comment 2 haiyang,dong 2014-08-12 07:00:49 UTC
Test version:
rhev-hypervisor7-7.0-20140807.0.iso
ovirt-node-3.1.0-0.6.20140731git2c8e71f.el7.noarch

Still prompt "Command [firewall-cmd, --reload] returned non-zero exit status 252" when configuring ssh

so need to re-assigned this bug again

Comment 3 Douglas Schilling Landgraf 2014-08-27 16:52:31 UTC
Hi Fabian,

I don't see this report in branch ovirt-3.5 or master (upstream). Are we going to do a new rebase soon?

Comment 4 Douglas Schilling Landgraf 2014-08-29 01:21:15 UTC
Moving to POST until we get a new RHEV-H7 for tests as in upstream which we base the release is working correctly.

Comment 5 Fabian Deutsch 2014-09-02 14:03:21 UTC
If the bug is correctly referenced in the commit msg, then I'll update this bug (move it to MODIFIED) as soon as I put together a new d/s snapshot.

Comment 6 Douglas Schilling Landgraf 2014-09-09 14:25:17 UTC
Moving to ON_QA since we have new rhev-h7 image for tests (rhev-hypervisor7-7.0-20140904.0) and I don't see the report on it.

Comment 7 haiyang,dong 2014-10-17 08:39:12 UTC
Test version:
rhev-hypervisor7-7.0-20141006.0.el7ev
ovirt-node-3.1.0-0.20.20141006gitc421e04.el7.noarch.rpm

Test steps:
configure ssh enabled and disabled success in rhev-hypervisor7-7.0-20141006.0.el7ev iso.
so this bug has been fixed, change the status into "VERIFIED".

Comment 10 errata-xmlrpc 2015-02-11 20:59:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.