Bug 1120567 - Cannot run runuser in unprivileged container
Summary: Cannot run runuser in unprivileged container
Keywords:
Status: CLOSED DUPLICATE of bug 1119849
Alias: None
Product: Fedora
Classification: Fedora
Component: docker-io
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lokesh Mandvekar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-17 07:36 UTC by Jan Pazdziora
Modified: 2014-07-17 09:40 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-17 09:40:53 UTC


Attachments (Terms of Use)

Description Jan Pazdziora 2014-07-17 07:36:49 UTC
Description of problem:

Attempt to run runuser in unprivileged container fails with runuser: System error.

Version-Release number of selected component (if applicable):

docker-io-1.0.0-6.fc20.x86_64

How reproducible:

Deterministic.

Steps to Reproduce:
1. docker run -ti fedora:20 runuser -u ftp id

Actual results:

runuser: System error

Expected results:

uid=14(ftp) gid=50(ftp) groups=50(ftp)

Additional info:

This is a regression against RHEL 7's docker-0.11.1-22.el7.x86_64 and I also believe against older Fedora 20 dockers.

When run in --privileged container, things work.

This blocks our effort to run FreeIPA in unprivileged containers: https://github.com/adelton/docker-freeipa/blob/master/systemctl

Comment 1 Marek Goldmann 2014-07-17 09:40:53 UTC
This is the same issue as in bug 1119849, closing this one.

*** This bug has been marked as a duplicate of bug 1119849 ***


Note You need to log in before you can comment on or make changes to this bug.