Bug 1120571 - Set German keyboard layout doesn't work
Summary: Set German keyboard layout doesn't work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Douglas Schilling Landgraf
QA Contact: cshao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-17 07:58 UTC by cshao
Modified: 2016-03-09 14:12 UTC (History)
10 users (show)

Fixed In Version: ovirt-node-3.3.0-0.4.20150906git14a6024.el7ev
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-09 14:12:54 UTC
oVirt Team: Node


Attachments (Terms of Use)
ovirt-node.log (73.18 KB, text/plain)
2014-07-17 08:27 UTC, cshao
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0378 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update for RHEV 3.6 2016-03-09 19:06:36 UTC

Description cshao 2014-07-17 07:58:21 UTC
Description of problem:
Set German keyboard layout doesn't work, the keyboard layout same as US.

# cat /etc/default/ovirt  | grep KEYBOARD
OVIRT_KEYBOARD_LAYOUT="de"

# ll /etc/sysconfig/keyboard
ls: cannot access /etc/sysconfig/keyboard: No such file or directory

Version-Release number of selected component (if applicable):
rhev-hypervisor7-7.0-20140714.0
ovirt-node-3.1.0-0.5.20140711git7197118.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install rhev-hypervisor7-7.0-20140714.0.iso
2. Enter keyboard menu.
3. Set keyboard layout to "German".

Actual results:
Set German keyboard layout doesn't work,the keyboard layout same as US.

Expected results:
Set German keyboard layout can work fine.

Additional info:

Comment 1 Fabian Deutsch 2014-07-17 08:16:20 UTC
Chen, could you please attach /var/log/ovirt-node.log ?

Comment 2 cshao 2014-07-17 08:27:11 UTC
Created attachment 918637 [details]
ovirt-node.log

Comment 3 Ryan Barry 2014-08-06 18:46:54 UTC
Is this reproducable on EL6, or is it a new problem with RHEH-H 7 images?

Comment 4 cshao 2014-08-06 23:06:21 UTC
(In reply to Ryan Barry from comment #3)
> Is this reproducable on EL6, or is it a new problem with RHEH-H 7 images?

Can't reproduce on el6, it should be a new issue with RHEV-H 7 images.
Thanks!

Comment 5 Fabian Deutsch 2014-11-06 14:53:54 UTC
Re-targeting for 3.6

Comment 6 Douglas Schilling Landgraf 2014-12-05 21:52:47 UTC
Hi,

(In reply to shaochen from comment #0)
> Description of problem:
> Set German keyboard layout doesn't work, the keyboard layout same as US.
> 
> # cat /etc/default/ovirt  | grep KEYBOARD
> OVIRT_KEYBOARD_LAYOUT="de"
> 
> # ll /etc/sysconfig/keyboard
> ls: cannot access /etc/sysconfig/keyboard: No such file or directory
> 

In EL7 systemd reads /etc/vconsole.conf instead of /etc/sysconfig/keyboard

> Version-Release number of selected component (if applicable):
> rhev-hypervisor7-7.0-20140714.0
> ovirt-node-3.1.0-0.5.20140711git7197118.el7.noarch
> 
> How reproducible:
> 100%
> 
> Steps to Reproduce:
> 1. Install rhev-hypervisor7-7.0-20140714.0.iso
> 2. Enter keyboard menu.
> 3. Set keyboard layout to "German".
> 
> Actual results:
> Set German keyboard layout doesn't work,the keyboard layout same as US.
> 
> Expected results:
> Set German keyboard layout can work fine.
> 
> Additional info:

I have tested Red Hat Enterprise Virtualization Hypervisor release 7.0 (20141202.0.el7ev) and everything is working as expected as systemd now reads a different file.

Commands and outputs from tests:

# cat /etc/vconsole.conf
KEYMAP=de
FONT=latarcyrheb-sun16

# localectl status
  System Locale: LANG=en_US.utf8
  VC Keymap: de
  X11 Layout: n/a

Additional data:
I could see my US keyboard behaving as DE keyboard. Some keys are acting in a pretty different layout.

Comment 7 Ying Cui 2015-03-19 11:47:35 UTC
This bug was ON_QA last year, was not attached into ovirt-node 3.5.0 GA errata, and bug target to 3.6.0.

Chen, see comment 6, could you please retest it on rhevh 7.0 for rhev 3.5.0 GA build, if it works, we can close this bug as current release. Thanks.

Comment 8 cshao 2015-03-20 03:03:47 UTC
Set German keyboard layout still doesn't work on rhevh 7.0 for rhev 3.5.0 GA build
The result of my keyboard behaving still as US keyboard.

# cat /etc/issue
Red Hat Enterprise Virtualization Hypervisor 7.0 (20150127.0.el7ev)
Kernel \r on an \m (\l)

# cat /etc/vconsole.conf 
KEYMAP="us"
FONT="latarcyrheb-sun16"

# localectl status
   System Locale: LANG=en_US.utf8
       VC Keymap: de
      X11 Layout: de
       X11 Model: pc105
     X11 Options: terminate:ctrl_alt_bksp

Comment 9 cshao 2015-03-20 05:25:32 UTC
# cat /etc/issue
Red Hat Enterprise Virtualization Hypervisor 7.1 (20150312.0.el7ev)

# rpm -qa | grep ovirt-node
ovirt-node-3.2.1-10.el7.noarch

# cat /etc/vconsole.conf 
KEYMAP="us"
FONT="latarcyrheb-sun16"

# local
local      locale     localectl  localedef  
[root@dell-op740-03 admin]# localectl status
   System Locale: LANG=en_US.utf8
       VC Keymap: de
      X11 Layout: de
       X11 Model: pc105
     X11 Options: terminate:ctrl_alt_bksp

The same issue occurs on latest 7.1 build, so assigned this bug.

Comment 10 Douglas Schilling Landgraf 2015-06-15 19:25:26 UTC
(In reply to shaochen from comment #9)
> # cat /etc/issue
> Red Hat Enterprise Virtualization Hypervisor 7.1 (20150312.0.el7ev)
> 
> # rpm -qa | grep ovirt-node
> ovirt-node-3.2.1-10.el7.noarch
> 
> # cat /etc/vconsole.conf 
> KEYMAP="us"
> FONT="latarcyrheb-sun16"
> 
> # local
> local      locale     localectl  localedef  
> [root@dell-op740-03 admin]# localectl status
>    System Locale: LANG=en_US.utf8
>        VC Keymap: de
>       X11 Layout: de
>        X11 Model: pc105
>      X11 Options: terminate:ctrl_alt_bksp
> 
> The same issue occurs on latest 7.1 build, so assigned this bug.

Hi shaochen,

I still cannot reproduce the report, this time using: rhev-hypervisor7-7.1-20150609.0. I have tested in 7.1 as the targeted version for this report is 3.6 which will be based in EL7.1.

- During the install, I have selected German as the keyboard layout.
- After the installation, the Keyboard tab in TUI shows:
    Current Active Keyboard Layout: German
- Went to shell and see my keyboard keys totally different, additional data shared below:

# cat /etc/vconsole.conf 
KEYMAP=de
FONT=latarcyrheb-sun16

# localectl status
   System Locale: LANG=en_US.utf8
       VC Keymap: de
      X11 Layout: n/a

Moving back to ON_QA for double check.

Thanks!

Comment 13 cshao 2015-11-23 06:46:31 UTC
Test version:
rhev-hypervisor7-7.2-20151112.1
ovirt-node-3.6.0-0.20.20151103git3d3779a.el7ev.noarch

Test steps:
1. Install rhev-hypervisor7.2
2. Enter keyboard menu.
3. Set keyboard layout to "German".

Test result:
Set German keyboard layout can work fine.

So the bug is fixed, change bug status to VERIFIED.

Comment 15 errata-xmlrpc 2016-03-09 14:12:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0378.html


Note You need to log in before you can comment on or make changes to this bug.