Bug 1120593 - Hypervisor failed to register to satellite
Summary: Hypervisor failed to register to satellite
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.5.0
Assignee: Ryan Barry
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-17 08:53 UTC by cshao
Modified: 2016-02-10 20:06 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-24 14:15:14 UTC
oVirt Team: Node


Attachments (Terms of Use)
ovirt-node.log (73.18 KB, text/plain)
2014-07-17 08:55 UTC, cshao
no flags Details

Description cshao 2014-07-17 08:53:32 UTC
Description of problem:
Hypervisor failed to register to satellite

Version-Release number of selected component (if applicable):
rhev-hypervisor7-7.0-20140714.0
ovirt-node-3.1.0-0.5.20140711git7197118.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install rhev-hypervisor7-7.0-20140714.0.iso
2. Enter RHN menu and register to satellite with correct steps.
3.

Actual results:
Failed to register to satellite and SAM

Expected results:
Register to satellite can successful.

Additional info:
ovirt-node.log
===================================================
2014-07-17 07:54:02,316      ERROR Failed to call: ['/usr/sbin/rhnreg_ks', '--serverUrl', 'https://10.66.111.195/XMLRPC', '--sslCACert', '/etc/sysconfig/rhn/RHN-ORG-TRUSTED-SSL-CERT', '--username', 'ycui', '--password', 'XXXXXXX', '--novirtinfo', '--norhnsd', '--nopackages', '--force']
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/ovirt/node/setup/rhn/rhn_model.py", line 187, in commit
  File "/usr/lib64/python2.7/subprocess.py", line 542, in check_call
CalledProcessError: Command '['/usr/sbin/rhnreg_ks', '--serverUrl', 'https://10.66.111.195/XMLRPC', '--sslCACert', '/etc/sysconfig/rhn/RHN-ORG-TRUSTED-SSL-CERT', '--username', 'ycui', '--password', u'12345678', '--novirtinfo', '--norhnsd', '--nopackages', '--force']' returned non-zero exit status 1
2014-07-17 07:54:02,316       INFO Captured nothing
2014-07-17 07:54:02,316       INFO An exception during the transaction: Error registering to RHN account
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/ovirt/node/ui/__init__.py", line 949, in __run_transaction
  File "/usr/lib/python2.7/site-packages/ovirt/node/plugins.py", line 188, in dry_or
  File "/usr/lib/python2.7/site-packages/ovirt/node/ui/__init__.py", line 949, in <lambda>
  File "/usr/lib/python2.7/site-packages/ovirt/node/setup/rhn/rhn_model.py", line 199, in commit
RuntimeError: Error registering to RHN account
2014-07-17 07:54:02,330       INFO Changes were merged successfully

Comment 1 cshao 2014-07-17 08:55:26 UTC
Created attachment 918643 [details]
ovirt-node.log

Comment 2 Ryan Barry 2014-07-17 17:38:34 UTC
Can you please try dropping to a shell and running the registration manually? (after trying it from the TUI, which will grab the CA cert)

/usr/sbin/rhnreg_ks --serverUrl https://10.66.111.195/XMLRPC --sslCACert /etc/sysconfig/rhn/RHN-ORG-TRUSTED-SSL-CERT --username ycui --password 12345678 --novirtinfo

I'm curious what gets returned. I don't have access to a Satellite server with 7 channels synced (working on it), but I'm wonderign if it's the same problem -- "Error Class Code: 70", which is "no entitlements or appropriate channels", since there are no RHEL7 channels.

Comment 10 Fabian Deutsch 2014-09-24 14:15:14 UTC
Closing this as; as said in comment 9 this is not a bug.


Note You need to log in before you can comment on or make changes to this bug.