Bug 112060 - Selecting version does not update component list
Selecting version does not update component list
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
3.2
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
David Lawrence
https://bugzilla.redhat.com/bugzilla/...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-13 16:15 EST by Matthew Saltzman
Modified: 2013-06-23 22:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-17 14:22:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Saltzman 2003-12-13 16:15:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031016

Description of problem:
Selecting a product clears the Component list.  Selecting a version
should reload that list with compnents of the selected  version of the
selected product.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Visit the "simple query" page of bugzilla.redhat.com
2. Select any product other than the default.
3. Select any version
    

Actual Results:  After step 2, the Component list is cleared.  After
step 3, it remains cleared.  Hitting browser's reload button reloads
the page with the correct component list.

Expected Results:  After step 3, the Component list should be updated
with the correct components.

Additional info:

Browser is Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031016.
Comment 1 David Lawrence 2003-12-13 18:11:22 EST
This does not occur for me when using Mozilla-1.4. I will have to
download a version of 1.5 and try it to see if it is a regression in
the browser or the standard has changed causeing the jscript on the
query page to break. Does this work for you if you use an older
version of Mozilla?
Comment 2 Matthew Saltzman 2003-12-18 17:49:12 EST
You're right 1.4.1 does not have the problem.  In fact, it is clear
now that the point at which the component list should be updated is
when the product is selected, rather than when the version is selected.

Furthermore, the problem doesn't recur today with Moz 1.5.  Did you
update something?  (If not, then it may be a Solaris-specific Moz bug.)
Comment 3 Matthew Saltzman 2003-12-26 14:24:18 EST
Update:  The exact sequence of events is this (and it is still
happening with Moz 1.5).  Go to bugzilla.redhat.com.  Select "Query"
form the menu bar.  Select "Fedora Core" from the product list.  The
component list goes blank (whereas it should be updated to contain FC
components).  Hit "Reload".  The component list is refreshed.
Comment 4 David Lawrence 2006-04-08 13:41:35 EDT
Red Hat's current Bugzilla version is 2.18. I am moving all older open bugs to
this version. Any bugs against the older versions will need to be verified that
they are still bugs. This will help me also to sort them better.
Comment 5 Matthew Saltzman 2006-04-08 16:46:30 EDT
I think this one is fixed.  I can't reproduce the problem behavior at this point.
Comment 6 David Lawrence 2008-09-16 12:50:40 EDT
Red Hat Bugzilla is now using version 3.2 of the Bugzilla codebase and therefore this bug will need to be re-verified against the new release. With the updated code this bug may no longer be relevant or may have been fixed in the new code.
Updating bug version to 3.2.
Comment 7 Matthew Saltzman 2008-09-17 13:59:05 EDT
I believe this is either fixed or no longer relevant and can be closed.
Comment 8 David Lawrence 2008-09-17 14:22:37 EDT
Thanks for verifying. Closing.

Dave

Note You need to log in before you can comment on or make changes to this bug.