Bug 1120602 - The neutron-agent-cleanup ocf resources are missing in the pacemaker modules
Summary: The neutron-agent-cleanup ocf resources are missing in the pacemaker modules
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-foreman-installer
Version: 5.0 (RHEL 7)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ga
: Installer
Assignee: Jason Guiditta
QA Contact: Leonid Natapov
URL:
Whiteboard:
Depends On: 1120584
Blocks: 1083890
TreeView+ depends on / blocked
 
Reported: 2014-07-17 09:13 UTC by Miguel Angel Ajo
Modified: 2016-04-26 17:10 UTC (History)
7 users (show)

Fixed In Version: openstack-foreman-installer-2.0.20-1.el6ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-21 18:05:38 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1090 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Enhancement Advisory 2014-08-22 15:28:08 UTC

Description Miguel Angel Ajo 2014-07-17 09:13:54 UTC
Description of problem:

This is missing
https://github.com/fabbione/rhos-ha-deploy/blob/master/rhos5-rhel7/mrgcloud-setup/RHOS-RHEL-HA-how-to-mrgcloud-rhos5-on-rhel7-neutron-n-latest.txt#L100

Around here:

https://github.com/redhat-openstack/astapor/blob/master/puppet/modules/quickstack/manifests/pacemaker/neutron.pp#L129

Version-Release number of selected component (if applicable):

openstack-foreman-installer-2.0.15-1.el6ost.noarch

Comment 1 Miguel Angel Ajo 2014-07-17 09:14:35 UTC
just a note, we introduced this change after the neutron.pp was ready.

Comment 4 Miguel Angel Ajo 2014-07-17 14:16:28 UTC
This part is important because it handles the cleanup of resources when we migrate agents from one host to another. 

Otherwise the resources (qrouter, qdhcp, could be left alone without the agent, and conflicting to what the new agent creates).

Comment 5 Miguel Angel Ajo 2014-07-17 14:30:50 UTC
Pull request for the changes, but needs a review,

https://github.com/redhat-openstack/astapor/pull/319

I don't have a working environment to actually check it's correct.

Comment 6 Jason Guiditta 2014-07-21 14:07:11 UTC
This is now mostly working, though it needs a newer version of the neutron rpms (-3 or later).  Once that is definitely readily available and we have my fixes to this patch in a new pull request (including Miguel's previous patch) it should be ok to merge (also depends on a pull request updating puppet-pacemaker, which was just merged today)

Comment 7 Jason Guiditta 2014-07-21 20:48:23 UTC
Updated PR here:

https://github.com/redhat-openstack/astapor/pull/323

Comment 9 Jason Guiditta 2014-08-12 14:06:48 UTC
This is ready to merge, but is waiting on a new opm build for https://bugzilla.redhat.com/show_bug.cgi?id=1120584 before we can do so

Comment 10 Crag Wolfe 2014-08-13 16:36:10 UTC
Confirmed that needed puppet-pacemaker addition is in openstack-puppet-modules-2014.1-20.el6os.

Comment 22 Leonid Natapov 2014-08-19 20:18:58 UTC
openstack-foreman-installer-2.0.21-1.el6ost resources are there.

Clone Set: neutron-ovs-cleanup-clone [neutron-ovs-cleanup]
     Started: [ mac848f69fbc49f.example.com mac848f69fbc643.example.com macf04da2732fb1.example.com ]
 Clone Set: neutron-netns-cleanup-clone [neutron-netns-cleanup]
     Started: [ mac848f69fbc49f.example.com mac848f69fbc643.example.com macf04da2732fb1.example.com ]

Comment 23 errata-xmlrpc 2014-08-21 18:05:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1090.html

Comment 24 Miguel Angel Ajo 2015-11-24 09:18:58 UTC
cleaning up flags


Note You need to log in before you can comment on or make changes to this bug.