Bug 1120638 - nrpe fails to bind to device on boot, fails to start
Summary: nrpe fails to bind to device on boot, fails to start
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: nrpe
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Scott Wilkerson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-17 10:08 UTC by Sergio Pascual
Modified: 2018-02-07 09:43 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-09-11 18:06:15 UTC


Attachments (Terms of Use)

Description Sergio Pascual 2014-07-17 10:08:27 UTC
Description of problem:
nrpe fails to start on boot with the following message in journal

Network server bind failure (99: Cannot assign requested address)

In /etc/nagios/nrpe.cfg I have set

server_address=xxx.xxx.xxx.xxx

because my host has several networks devices I do not want to bind to all of them.

Version-Release number of selected component (if applicable):
nrpe-2.14-5.fc20.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Uncomment the server_address line from nrpe.cfg
2. Set nrpe to start on boot
3. Reboot

Actual results:
nrpe fails to start

Expected results:
nrpe starts on boot

Additional info:
If I do 'systemctl start nrpe.service' after boot, nrpe starts
If I comment the 'server_address' line, then nrpe starts on boot

Comment 1 Fedora Admin XMLRPC Client 2015-08-31 15:10:51 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 2 Fedora Admin XMLRPC Client 2015-08-31 15:16:17 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 3 Scott Wilkerson 2015-09-11 14:37:00 UTC
This sounds like your network connection that is assigning xxx.xxx.xxx.xxx is coming up late in the boot cycle, AFTER nrpe is attempting to start.

Comment 4 Sergio Pascual 2015-09-11 15:33:08 UTC
Yes, I agree

Comment 5 Scott Wilkerson 2015-09-11 18:06:15 UTC
As such, there is no way for nrpe to bind to an address that doesn't exist, and I would have to mark this as expected behavior.

Comment 6 John 2017-12-20 15:30:51 UTC
This problem reported 3 1/2 years ago, and yet, here i am, having my time wasted, because the problem still exists in el7, and fedora 27.

Closing this bug was a pathetic response.

How about setting up your initscripts or systemd units so nrpe starts AFTER the networking units eh?

If this is too much bother for *YOU* to do, what in the seven hells gives you the right to waste your user's time by requiring them to do it?

Comment 7 John 2017-12-20 15:49:10 UTC
Until nagios maintainers address this issue, you can resolve it by creating a systemd drop-in. Create the file: /etc/systemd/system/nrpe.service.d/nrpe.conf containing:

[Unit]
Requires=network-online.target
After=network-online.target

Reboot, and you should see that systemd has started nrpe after your network has come up, and so nrpe should start successfully.

The systemd unit files (and initscripts for sysv distros) for nagios *should* do this themselves, and it is a bug in nrpe that they don't 

Whoever looks after nrpe should fix this ASAP.


Note You need to log in before you can comment on or make changes to this bug.