Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 1120646 - rfc.sh transfers patches with whitespace problems without warning [provide coding guidelines check]
rfc.sh transfers patches with whitespace problems without warning [provide co...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: unclassified (Show other bugs)
pre-release
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: bugs@gluster.org
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-07-17 06:40 EDT by Anders Blomdell
Modified: 2015-05-14 13:42 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-05-14 13:26:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anders Blomdell 2014-07-17 06:40:44 EDT
Description of problem:

When pushing patches with rfc.sh, sloppy programmers might easily
submit patches with bogus whitespace in them, therby consuming
valuable reviewer bandwidth.

Version-Release number of selected component (if applicable):

v3.5qa2-760-ge291ce0
Comment 1 Anand Avati 2014-07-17 06:43:12 EDT
REVIEW: http://review.gluster.org/8325 (Check if the review going up contains possibly invalid whitespace.) posted (#1) for review on master by Anders Blomdell (anders.blomdell@control.lth.se)
Comment 2 Anand Avati 2014-07-17 08:39:46 EDT
REVIEW: http://review.gluster.org/8325 (Check if the review going up contains possibly invalid whitespace.) posted (#2) for review on master by Anders Blomdell (anders.blomdell@control.lth.se)
Comment 3 Anand Avati 2014-07-17 08:42:21 EDT
REVIEW: http://review.gluster.org/8325 (Check if the review going up contains possibly invalid whitespace.) posted (#3) for review on master by Anders Blomdell (anders.blomdell@control.lth.se)
Comment 4 Anand Avati 2014-07-17 11:18:19 EDT
REVIEW: http://review.gluster.org/8325 (Check if the review going up contains possibly invalid whitespace.) posted (#4) for review on master by Anders Blomdell (anders.blomdell@control.lth.se)
Comment 5 Anand Avati 2014-07-17 11:20:05 EDT
REVIEW: http://review.gluster.org/8325 (Check if the review for invalid whitespace.) posted (#5) for review on master by Anders Blomdell (anders.blomdell@control.lth.se)
Comment 6 Anand Avati 2014-07-17 11:30:06 EDT
REVIEW: http://review.gluster.org/8325 (Check the review for invalid whitespace.) posted (#6) for review on master by Anders Blomdell (anders.blomdell@control.lth.se)
Comment 7 Anand Avati 2014-07-17 11:42:31 EDT
REVIEW: http://review.gluster.org/8325 (Check the review for invalid whitespace.) posted (#7) for review on master by Anders Blomdell (anders.blomdell@control.lth.se)
Comment 8 Anand Avati 2014-07-17 11:56:03 EDT
REVIEW: http://review.gluster.org/8325 (Check the review for invalid whitespace.) posted (#8) for review on master by Anders Blomdell (anders.blomdell@control.lth.se)
Comment 9 Anders Blomdell 2014-07-30 06:57:42 EDT
I suggest this http://review.gluster.org/#/c/8181/ since it's much more comprehensive.
Comment 10 Anand Avati 2014-07-30 12:58:09 EDT
REVIEW: http://review.gluster.org/8181 (extras/checkpatch.pl: linux kernel style patch verification) posted (#5) for review on master by Anders Blomdell (anders.blomdell@control.lth.se)
Comment 11 Anand Avati 2014-07-31 03:54:16 EDT
REVIEW: http://review.gluster.org/8181 (extras/checkpatch.pl: linux kernel style patch verification) posted (#6) for review on master by Harshavardhana (harsha@harshavardhana.net)
Comment 12 Anand Avati 2014-08-01 12:36:04 EDT
REVIEW: http://review.gluster.org/8181 (extras/checkpatch.pl: linux kernel style patch verification) posted (#7) for review on master by Harshavardhana (harsha@harshavardhana.net)
Comment 13 Anand Avati 2014-08-01 13:07:35 EDT
REVIEW: http://review.gluster.org/8181 (extras/checkpatch.pl: linux kernel style patch verification) posted (#8) for review on master by Anders Blomdell (anders.blomdell@control.lth.se)
Comment 14 Anand Avati 2014-08-02 13:52:40 EDT
REVIEW: http://review.gluster.org/8181 (extras/checkpatch.pl: linux kernel style patch verification) posted (#9) for review on master by Harshavardhana (harsha@harshavardhana.net)
Comment 15 Anand Avati 2014-08-02 13:54:28 EDT
REVIEW: http://review.gluster.org/8181 (extras/checkpatch.pl: linux kernel style patch verification) posted (#10) for review on master by Harshavardhana (harsha@harshavardhana.net)
Comment 16 Anand Avati 2014-08-02 14:04:28 EDT
REVIEW: http://review.gluster.org/8181 (extras/checkpatch.pl: linux kernel style patch verification) posted (#11) for review on master by Harshavardhana (harsha@harshavardhana.net)
Comment 17 Anand Avati 2014-08-02 15:51:21 EDT
REVIEW: http://review.gluster.org/8181 (extras/checkpatch.pl: linux kernel style patch verification) posted (#12) for review on master by Harshavardhana (harsha@harshavardhana.net)
Comment 18 Anand Avati 2014-08-02 16:01:50 EDT
REVIEW: http://review.gluster.org/8181 (extras/checkpatch.pl: linux kernel style patch verification) posted (#13) for review on master by Harshavardhana (harsha@harshavardhana.net)
Comment 19 Anand Avati 2014-08-04 03:58:23 EDT
REVIEW: http://review.gluster.org/8181 (extras/checkpatch.pl: linux kernel style patch verification) posted (#14) for review on master by Harshavardhana (harsha@harshavardhana.net)
Comment 20 Anand Avati 2014-08-07 04:24:23 EDT
REVIEW: http://review.gluster.org/8181 (extras/checkpatch.pl: linux kernel style patch verification) posted (#15) for review on master by Harshavardhana (harsha@harshavardhana.net)
Comment 21 Anand Avati 2014-09-02 00:57:44 EDT
REVIEW: http://review.gluster.org/8181 (extras/checkpatch.pl: linux kernel style patch verification) posted (#16) for review on master by Harshavardhana (harsha@harshavardhana.net)
Comment 22 Anand Avati 2014-09-02 04:06:45 EDT
REVIEW: http://review.gluster.org/8181 (extras/checkpatch.pl: linux kernel style patch verification) posted (#17) for review on master by Harshavardhana (harsha@harshavardhana.net)
Comment 23 Anand Avati 2014-09-02 16:25:34 EDT
REVIEW: http://review.gluster.org/8181 (extras/checkpatch.pl: linux kernel style patch verification) posted (#18) for review on master by Harshavardhana (harsha@harshavardhana.net)
Comment 24 Anand Avati 2014-09-02 16:26:40 EDT
REVIEW: http://review.gluster.org/8181 (extras/checkpatch.pl: linux kernel style patch verification) posted (#19) for review on master by Harshavardhana (harsha@harshavardhana.net)
Comment 25 Anand Avati 2014-09-02 16:31:04 EDT
REVIEW: http://review.gluster.org/8181 (extras/checkpatch.pl: linux kernel style patch verification) posted (#20) for review on master by Harshavardhana (harsha@harshavardhana.net)
Comment 26 Anand Avati 2014-09-03 14:16:18 EDT
REVIEW: http://review.gluster.org/8181 (extras/checkpatch.pl: linux kernel style patch verification) posted (#21) for review on master by Harshavardhana (harsha@harshavardhana.net)
Comment 27 Anand Avati 2014-09-04 04:48:20 EDT
REVIEW: http://review.gluster.org/8181 (extras/checkpatch.pl: linux kernel style patch verification) posted (#22) for review on master by Anders Blomdell (anders.blomdell@control.lth.se)
Comment 28 Anand Avati 2014-09-05 23:45:41 EDT
REVIEW: http://review.gluster.org/8181 (extras/checkpatch.pl: linux kernel style patch verification) posted (#23) for review on master by Harshavardhana (harsha@harshavardhana.net)
Comment 29 Anand Avati 2014-09-05 23:51:01 EDT
REVIEW: http://review.gluster.org/8181 (extras/checkpatch.pl: linux kernel style patch verification) posted (#24) for review on master by Harshavardhana (harsha@harshavardhana.net)
Comment 30 Anand Avati 2014-09-18 15:55:30 EDT
COMMIT: http://review.gluster.org/8181 committed in master by Harshavardhana (harsha@harshavardhana.net) 
------
commit c788a7784d8526b72714d60bac6e1e09ae985a84
Author: Harshavardhana <harsha@harshavardhana.net>
Date:   Wed Jun 25 21:22:49 2014 -0700

    extras/checkpatch.pl: linux kernel style patch verification
    
    This is to bring in adherence to coding policy, prior to patch
    submission for review.
    
     - no tabs
     - no whitespace
     - indentation (linux style) etc.
    
    This is in the interest at large for the GlusterFS codebase
    to be more cleaner and readable.
    
    ./rfc.sh - now supports running this for all patches diverged
    from "origin/master" revision.
    
    NOTE: One should take this as a handle for good guidelines and
    never use it as a tool for correctness, use common-sense in all
    the cases ;-)
    
    Change-Id: Ib9a5ed207cde152cb92b8d38cec83e8ce9ef7f28
    BUG: 1120646
    Signed-off-by: Harshavardhana <harsha@harshavardhana.net>
    Reviewed-on: http://review.gluster.org/8181
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anders Blomdell <anders.blomdell@control.lth.se>
Comment 31 Anand Avati 2014-09-22 14:02:30 EDT
REVIEW: http://review.gluster.org/8811 (extras/checkpatch.pl: update coding guidelines script) posted (#1) for review on master by Harshavardhana (harsha@harshavardhana.net)
Comment 32 Anand Avati 2014-09-23 15:29:21 EDT
COMMIT: http://review.gluster.org/8811 committed in master by Harshavardhana (harsha@harshavardhana.net) 
------
commit 2288fec13e5fa8f1b2493fd75e35f748460b2039
Author: Harshavardhana <harsha@harshavardhana.net>
Date:   Mon Sep 22 10:59:37 2014 -0700

    extras/checkpatch.pl: update coding guidelines script
    
    - Allow 'quoted string split across lines' since its a
      GlusterFS common practice
    - Remove a useless "+" - perl 5.20 complains with following
      warning "Useless use of greediness modifier '+'"
    
    Change-Id: Ibaf276ec84757b3ecc3e6db7f5e720b8e8a12dff
    BUG: 1120646
    Signed-off-by: Harshavardhana <harsha@harshavardhana.net>
    Reviewed-on: http://review.gluster.org/8811
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
Comment 33 Anand Avati 2014-09-23 15:47:14 EDT
REVIEW: http://review.gluster.org/8813 (build: remove warnings for recommended style) posted (#3) for review on master by Jeff Darcy (jdarcy@redhat.com)
Comment 34 Anand Avati 2014-09-23 15:48:22 EDT
REVIEW: http://review.gluster.org/8813 (build: remove warnings for recommended style) posted (#4) for review on master by Jeff Darcy (jdarcy@redhat.com)
Comment 35 Anand Avati 2014-09-23 17:30:17 EDT
COMMIT: http://review.gluster.org/8813 committed in master by Harshavardhana (harsha@harshavardhana.net) 
------
commit 6e8ad12fbac943336f9eb8d97bf2e0bedb9fb225
Author: Jeff Darcy <jdarcy@redhat.com>
Date:   Mon Sep 22 16:48:50 2014 -0400

    build: remove warnings for recommended style
    
    Specifically:
    
     * space before function arguments
    
     * brace around single statement
    
    Ideally we would *reverse* these tests so they warn under the exact
    opposite conditions, but that would mean learning the internals of a
    script written in a defective language with cryptic variable names and
    too few comments.  Life's too short.  For now, just cutting down on some
    of the spam (which might obscure more serious issues) should suffice.
    
    BUG: 1120646
    Change-Id: I5ec684d0d788a34f29af9b1761743c8860973993
    Signed-off-by: Jeff Darcy <jdarcy@redhat.com>
    Reviewed-on: http://review.gluster.org/8813
    Reviewed-by: Harshavardhana <harsha@harshavardhana.net>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: Harshavardhana <harsha@harshavardhana.net>
Comment 36 Anand Avati 2014-10-13 18:21:20 EDT
REVIEW: http://review.gluster.org/8927 (Revert "extras: reverse test for '}' vs. following 'else' placement") posted (#1) for review on master by Harshavardhana (harsha@harshavardhana.net)
Comment 37 Anand Avati 2014-10-14 09:43:41 EDT
COMMIT: http://review.gluster.org/8927 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit 7808d4b7892ccd80bcabb1253ee359a64c51c612
Author: Harshavardhana <harsha@harshavardhana.net>
Date:   Mon Oct 13 15:19:35 2014 -0700

    Revert "extras: reverse test for '}' vs. following 'else' placement"
    
    This reverts commit 0a8371bdfdd88e662d09def717cc0b822feb64e8.
    
    Change-Id: I946f449ad213cea70fbbd9cd3951f5838b9f82e5
    BUG: 1120646
    Signed-off-by: Harshavardhana <harsha@harshavardhana.net>
    Reviewed-on: http://review.gluster.org/8927
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Tested-by: Niels de Vos <ndevos@redhat.com>
Comment 38 Anand Avati 2015-03-05 08:44:35 EST
REVIEW: http://review.gluster.org/9813 (checkpatch: Update tree) posted (#1) for review on master by Kaushal M (kaushal@redhat.com)
Comment 39 Niels de Vos 2015-05-14 13:26:21 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 40 Niels de Vos 2015-05-14 13:35:29 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 41 Niels de Vos 2015-05-14 13:37:50 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 42 Niels de Vos 2015-05-14 13:42:42 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.