Bug 1120647 - Converting a volume from replicate to distribute by reducing the replica count to one fails.
Summary: Converting a volume from replicate to distribute by reducing the replica coun...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Ravishankar N
QA Contact:
URL:
Whiteboard:
Depends On: 1120592
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-17 10:45 UTC by Ravishankar N
Modified: 2015-05-14 17:42 UTC (History)
5 users (show)

Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Clone Of: 1120592
Environment:
Last Closed: 2015-05-14 17:26:22 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Ravishankar N 2014-07-17 10:45:15 UTC
+++ This bug was initially created as a clone of Bug #1120592 +++

Description of problem:
Have a distribute replicate volume (2x2), remove exactly one pair of bricks so that it becomes a replicate volume (1x2) and removing a brick from the volume by reducing the replica count to 1 fails with error message "volume remove-brick commit force: failed: Remove exactly 1 brick(s) from each subvolume.

Version-Release number of selected component (if applicable):
glusterfs-3.6.0.22-1.el6rhs.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Have a distribute replicate volume of 2x2.
2. Remove a pair of bricks from the volume so that it becomes a replicate volume(1x2).
3. Remove another brick from the volume by reducing the replica count to 1 by running the command "gluster vol remove-brick <vol_name> replica 1 <brickpath> force.

Actual results:
It results in an error "volume remove-brick commit force: failed: Remove exactly 1 brick(s) from each subvolume.

Expected results:
user should be able to convert the volume to distribute type by reducing the replica count to 1.

Additional info:

--- Additional comment from RHEL Product and Program Management on 2014-07-17 04:53:20 EDT ---

Since this issue was entered in bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 1 Anand Avati 2014-07-17 11:07:00 UTC
REVIEW: http://review.gluster.org/8326 (glusterd: update volinfo->subvol_count during remove-brick operation.) posted (#1) for review on master by Ravishankar N (ravishankar@redhat.com)

Comment 2 Anand Avati 2014-07-25 06:29:08 UTC
COMMIT: http://review.gluster.org/8326 committed in master by Kaushal M (kaushal@redhat.com) 
------
commit c57895242fff0c05a24f99273f25cd793336f08d
Author: Ravishankar N <ravishankar@redhat.com>
Date:   Thu Jul 17 08:30:52 2014 +0000

    glusterd: update volinfo->subvol_count during remove-brick operation.
    
    Problem:
    In glusterd_op_remove_brick(), volinfo->subvol_count was getting updated only if
    the replica count was reduced due to which subvol_matcher_verify() gave false
    errors under certain scenarios (see bug description).
    
    Fix:
    updated subvol_count for every remove-brick operation.
    
    Change-Id: Id72691e2bda1c624cd7d8cae92f6bf32c101a6d3
    BUG: 1120647
    Signed-off-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-on: http://review.gluster.org/8326
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-by: Kaushal M <kaushal@redhat.com>

Comment 3 Niels de Vos 2015-05-14 17:26:22 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 4 Niels de Vos 2015-05-14 17:35:29 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 5 Niels de Vos 2015-05-14 17:37:50 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 6 Niels de Vos 2015-05-14 17:42:42 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.