Bug 1120663 - UI shouldn't switch to other tab while creating OS parameters with same name or with blank name/values
Summary: UI shouldn't switch to other tab while creating OS parameters with same name ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: orabin
QA Contact: sthirugn@redhat.com
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-17 11:42 UTC by Sachin Ghai
Modified: 2016-04-22 16:40 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-11 12:23:02 UTC


Attachments (Terms of Use)
error raised on creating OS parameters with blank name/value (15.16 KB, image/png)
2014-07-17 11:42 UTC, Sachin Ghai
no flags Details


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 6693 None None None 2016-04-22 16:40:24 UTC

Description Sachin Ghai 2014-07-17 11:42:26 UTC
Created attachment 918680 [details]
error raised on creating OS parameters with blank name/value

Description of problem:
I added OS parameter with blank name/value and UI raises error on submit but as soon as I submit the form, UI switched to main(Operating System) tab. It should stay on same 'Parameters' tab since error is raised under it.

Version-Release number of selected component (if applicable):
sat6 GA snap0

How reproducible:
always

Steps to Reproduce:
1. create OS with parameters name/value as blank
2. submit it
3.

Actual results:
when you submit the form with blank name/value for OS parameters, neither the form was submitted nor you will see any error. Actually error raised but it displays only under 'Parameters' tab. Also, on submit the form, UI quickly switches from 'parameters' tab to 'operating system' tab

Expected results:
Since UI raised error so, It should stay on same page/tab where error was raised.

Additional info:

Comment 2 orabin 2014-07-20 05:17:01 UTC
Created redmine issue http://projects.theforeman.org/issues/6693 from this bug

Comment 3 Bryan Kearney 2014-07-30 16:05:26 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/6693 has been closed
-------------
Ori Rabin
Applied in changeset commit:2b5f9c11bdcb158598dc80aaba51347615ca1c4f.

Comment 6 sthirugn@redhat.com 2014-08-10 05:13:24 UTC
Verified. The tabs are not switching anymore.

Version Tested:
GA Snap 4 - Satellite-6.0.4-RHEL-6-20140806.0

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.19-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.19-1.el6_5.noarch
* candlepin-tomcat6-0.9.19-1.el6_5.noarch
* elasticsearch-0.90.10-4.el6sat.noarch
* foreman-1.6.0.38-1.el6sat.noarch
* foreman-compute-1.6.0.38-1.el6sat.noarch
* foreman-gce-1.6.0.38-1.el6sat.noarch
* foreman-libvirt-1.6.0.38-1.el6sat.noarch
* foreman-ovirt-1.6.0.38-1.el6sat.noarch
* foreman-postgresql-1.6.0.38-1.el6sat.noarch
* foreman-proxy-1.6.0.23-1.el6sat.noarch
* foreman-selinux-1.6.0.4-1.el6sat.noarch
* foreman-vmware-1.6.0.38-1.el6sat.noarch
* katello-1.5.0-28.el6sat.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.6-1.el6sat.noarch
* katello-installer-0.0.57-1.el6sat.noarch
* openldap-2.4.23-34.el6_5.1.x86_64
* pulp-katello-0.3-3.el6sat.noarch
* pulp-nodes-common-2.4.0-0.30.beta.el6sat.noarch
* pulp-nodes-parent-2.4.0-0.30.beta.el6sat.noarch
* pulp-puppet-plugins-2.4.0-0.30.beta.el6sat.noarch
* pulp-puppet-tools-2.4.0-0.30.beta.el6sat.noarch
* pulp-rpm-plugins-2.4.0-0.30.beta.el6sat.noarch
* pulp-selinux-2.4.0-0.30.beta.el6sat.noarch
* pulp-server-2.4.0-0.30.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el6sat.noarch
* sssd-ldap-1.11.5.1-3.el6.x86_64

Comment 8 Bryan Kearney 2014-09-11 12:23:02 UTC
This was delivered with Satellite 6.0 which was released on 10 September 2014.


Note You need to log in before you can comment on or make changes to this bug.