Bug 1120698 - [RFE] Support generation of Puppet manifest documentation
Summary: [RFE] Support generation of Puppet manifest documentation
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Puppet
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Tomer Brisker
QA Contact: Katello QA List
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-17 13:41 UTC by Ivan Necas
Modified: 2017-01-08 14:25 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-08 14:25:35 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 1556 None None None 2016-04-22 15:11:50 UTC

Description Ivan Necas 2014-07-17 13:41:10 UTC
Description of problem:
To be able to generate the documentation for puppet classes accessible from foreman ui -> puppet classes -> the environment links in documentation column, 
`foreman-rake puppet:rdoc:generate` needs to be run. However, it expects puppetdoc command to be present. It seems, puppet 3.6 does not ship this script, and `puppet doc` should be used instead.

Even after the path is changes, there are still issues when loading the information about the puppet environments from the master:

foreman-rake puppet:rdoc:generate --trace

undefined method `keys' for ["motd", motd]:Array
/usr/share/foreman/app/models/environment.rb:45:in `block (2 levels) in puppetEnvs'
/usr/share/foreman/app/models/environment.rb:44:in `each'
/usr/share/foreman/app/models/environment.rb:44:in `map'
/usr/share/foreman/app/models/environment.rb:44:in `block in puppetEnvs'
/usr/share/foreman/app/models/environment.rb:43:in `map'
/usr/share/foreman/app/models/environment.rb:43:in `puppetEnvs'
/usr/share/foreman/app/models/puppetclass.rb:102:in `rdoc'
/usr/share/foreman/lib/tasks/puppet.rake:17:in `block (3 levels) in <top (required)>'
/opt/rh/ruby193/root/usr/share/ruby/rake/task.rb:205:in `call'
/opt/rh/ruby193/root/usr/share/ruby/rake/task.rb:205:in `block in execute'
/opt/rh/ruby193/root/usr/share/ruby/rake/task.rb:200:in `each'
/opt/rh/ruby193/root/usr/share/ruby/rake/task.rb:200:in `execute'
/opt/rh/ruby193/root/usr/share/ruby/rake/task.rb:158:in `block in invoke_with_call_chain'
/opt/rh/ruby193/root/usr/share/ruby/monitor.rb:211:in `mon_synchronize'
/opt/rh/ruby193/root/usr/share/ruby/rake/task.rb:151:in `invoke_with_call_chain'

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. create a content view with a puppet module and publish
2. run the `foreman-rake puppet:rdoc:generate`

Actual results:
Foreman is trying to use puppetdoc script, and even after fixing this, it fails on other errors

Expected results:


Additional info:

Comment 1 Ivan Necas 2014-07-17 13:44:41 UTC
Created redmine issue http://projects.theforeman.org/issues/6666 from this bug

Comment 3 Bryan Kearney 2014-07-28 20:30:21 UTC
Connecting redmine issue http://projects.theforeman.org/issues/1556 from this bug

Comment 4 Dominic Cleal 2014-08-01 14:06:15 UTC
Not providing devel_ack+ for this, it's likely CANTFIX or WONTFIX.  It'll need a more thorough review of bugs at multiple levels, and a redesign of the implementation.  It's quite a bit of work.

Comment 5 Bryan Kearney 2015-01-09 14:42:29 UTC
Upstream bug assigned to ohadlevy@redhat.com

Comment 6 Bryan Kearney 2015-08-25 17:24:48 UTC
Upstream bug component is WebUI

Comment 7 Bryan Kearney 2015-08-25 17:37:04 UTC
Upstream bug component is Provisioning

Comment 8 Bryan Kearney 2016-08-10 19:01:01 UTC
Upstream bug component is Configuration Management

Comment 9 Bryan Kearney 2016-08-10 20:02:10 UTC
Upstream bug component is Provisioning

Comment 10 Bryan Kearney 2016-08-10 22:02:00 UTC
Upstream bug component is Puppet

Comment 11 Bryan Kearney 2016-11-27 11:05:45 UTC
Upstream bug assigned to tbrisker@redhat.com

Comment 12 Bryan Kearney 2016-11-27 11:05:48 UTC
Upstream bug assigned to tbrisker@redhat.com

Comment 13 Bryan Kearney 2016-11-28 17:05:45 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/1556 has been resolved.

Comment 14 Tomer Brisker 2017-01-08 14:25:35 UTC
Closing this as can't fix. Puppet rdoc support has been dropped and there is currently no plan to reintroduce this. Upstream the related rake command has been removed already and this will land in Satellite as well when fix for https://bugzilla.redhat.com/show_bug.cgi?id=1243586 is pulled in.


Note You need to log in before you can comment on or make changes to this bug.